Bug 423991 - M6300 Back light does not go out when lid is closed
M6300 Back light does not go out when lid is closed
Status: CLOSED DUPLICATE of bug 423931
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-power-manager (Show other bugs)
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Richard Hughes
Depends On:
Blocks: 391501
  Show dependency treegraph
Reported: 2007-12-13 14:58 EST by Larry Troan
Modified: 2016-04-18 05:46 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-09-16 09:34:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Larry Troan 2007-12-13 14:58:54 EST
Description of problem:

Running RHEL5.1 x86_64, the Dell Precision Mobile M6300 backlight stays on when
the lid is closed. It needs to go out and stay out to pass certification.

How reproducible:
Power up the M6300, close the lid and observe the light by peering through the
slit between the keyboard and the top.

Actual results:
Back light stays on when lid is closed.

Expected results:
Back light should turn off and stay off to conserve battery power until lid is

Additional info:
Verify BIOS is latest before debugging (believe 01).
Comment 1 John Feeney 2008-01-30 11:23:08 EST
Dell has found that with the addition of "xset dpms on/off" directive, the 
binary nVidia driver will turn off the backlight when the lid is closed. Thus, 
it would appear as though the issue is in the nv and vesa xorg drivers.  As a
result, I am re-assigning this bugzilla.
Comment 4 Dave Maley 2008-06-05 15:38:50 EDT
re-assigning to g-p-m
Comment 5 RHEL Product and Program Management 2008-06-05 15:54:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
Comment 9 Adam Jackson 2008-06-23 10:40:56 EDT
(In reply to comment #8)
> Hello,
> Dell is asking if this has been reassigned to a g-p-m engineer.  Has this been
> considered yet?

The bug is in the g-p-m component, but I'm not the engineer for that.  Reassigning.
Comment 14 Matthias Clasen 2008-07-14 16:18:04 EDT
Acking it based on the fact that Richard proposed a solution further up:

"We can add a call into g-p-m to do the xset (it's there in later versions)"
Comment 15 Richard Hughes 2008-09-10 08:41:26 EDT
Can I close this bug as a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=423931 ?
Comment 19 Matthias Clasen 2008-09-16 09:34:31 EDT
Marking as duplicate, as discussed further up

*** This bug has been marked as a duplicate of bug 423931 ***

Note You need to log in before you can comment on or make changes to this bug.