Bug 424 - /boot/module-info problem
/boot/module-info problem
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-15 01:17 EST by Steve Wills
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-17 07:53:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wills 1998-12-15 01:17:42 EST
the /boot/module-info-<kernelversion> file doesn't contain
any reference to the bpcd.o module (used for back pack
cdroms). Because of this, it is not listed in the list of
available modules in kernelcfg.
Comment 1 David Lawrence 1998-12-22 18:11:59 EST
I have verified this bug to be true. The bpcd is a module that is
available with 5.2 but is not available to the kernelcfg application.
Comment 2 Steve Wills 1999-01-06 12:50:59 EST
Additionally, /boot/module-info-2.0.36-0.7 has the entry:

# NOT YET
MODULARIZED!
#lance
#
eth
#       "AMD LANCE: Allied Telesis AT1500, HP J2405A, most
NE2100/clone"

Yet the kernel defintly has this as a module.

It should read

lance
        eth
        "AMD LANCE: Allied Telesis AT1500, HP J2405A, most
NE2100/clone"
        io "Base I/O address" "0x[0-9a-fA-F]+"

It may also need a line
        irq "IRQ level" "[0-9]+"
Comment 3 Michael K. Johnson 1999-03-23 17:47:59 EST
Cristian, he's right, can you fix this the next time you build a
kernel package?  No point in building a new kernel just to fix this...

Note You need to log in before you can comment on or make changes to this bug.