Bug 424021 - M4300 and M6300 Keyboard "suspend" key doesn't work (Fn+F1)
Summary: M4300 and M6300 Keyboard "suspend" key doesn't work (Fn+F1)
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: John Feeney
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 442623
Blocks: KernelPrio5.3
TreeView+ depends on / blocked
 
Reported: 2007-12-13 20:05 UTC by Larry Troan
Modified: 2018-10-19 20:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 21:11:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Larry Troan 2007-12-13 20:05:58 UTC
Description of problem:

Using RHEL5.1 x86_64, the "suspend key" (Fn-F1) marked with a partial moon
figure fails to suspend the system

Version-Release number of selected component (if applicable):
RHEL5.1 x86_64

How reproducible:
Power up M4300 or M6300 with the smp kernel and press Fn+F1. Systems should
suspent. 
 
Actual results:
Nothing happens.

Expected results:
System should suspend.

Comment 1 Larry Troan 2007-12-13 20:11:07 UTC
Required to certify systems.

Comment 2 Rezwanul Kabir 2008-01-30 04:08:19 UTC
This issue needs to be fixed in RHEL5.2. Dell systems were blocked from 
getting RHEL5.1 certification due to this bug, so we would like to see more 
attention given to this bug.

Comment 3 John Feeney 2008-02-01 19:37:49 UTC
After some discussion, it appears as though this should be re-assigned 
because it is not a kernel problem.


Comment 4 Rezwanul Kabir 2008-02-13 19:02:42 UTC
This feature is to map the "suspend" key in M4300/M6300. Needs urgent 
attention for inclusion in RHEL5.2.

Comment 7 John Feeney 2008-04-22 19:34:49 UTC
bz442623 was opened to track the addition of quirks for keymaps in HAL so
this bugzilla will have to wait for that bugzilla's resolution. This bugzilla 
(bz424021) will track any M4300/M6300 specific changes required once the 
plumbing provided by 442623 is in place. As you will note, bz424021 has been
marked dependent upon bz442623.

Comment 9 John Feeney 2008-08-19 21:11:54 UTC
Since no kernel changes appear to be required to enable this functionality,
I am closing this (kernel-related) bugzilla.


Note You need to log in before you can comment on or make changes to this bug.