Bug 424041 - /sbin/loader won't start
/sbin/loader won't start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 15:25 EST by Armijn Hemel
Modified: 2008-12-08 06:04 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 06:04:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armijn Hemel 2007-12-13 15:25:08 EST
Description of problem:

On my Toshiba L100-129 I can't get Fedora 8 to install. I tried the DVD and a
network install. Both times nothing happened after 'running /sbin/loader'. X
wasn't started, nothing on the virtual consoles that indicated problems.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. get a Toshiba L100-129
2. download Fedora 8 DVD
3. boot
  
Actual results:

Anaconda is not started

Expected results:

Installer should start

Additional info:

The machine has been happily running Fedora Core 6 and Fedora 7. What can I do
to debug this (sounds like a fun thing to do during X-mas).
Comment 1 Jeremy Katz 2007-12-13 15:46:45 EST
Two things to try
1) How long did you let it sit?
2) Try booting with 'linux nopcmcia' and see if helps
Comment 2 Armijn Hemel 2007-12-13 16:05:11 EST
I let it sit for about three minutes.

I tried to boot with 'linux nopcmcia' (boot from DVD, when the menu comes up hit
ESC and type 'linux nopcmcia'), but I still see that the pcmcia stuff gets
loaded. No result.
Comment 3 Roland Siemons 2008-01-14 13:20:21 EST
Problem solved:

(I had the very same difficulty with my Acer Laptop Travelmate 290. I could
install Fedora 7 on it, but the F8 cd stayed hanging on "running sbin/loader".)

Solution:
Press [SHIFT] during boot. This gets you into text mode. Follow the instruction
that enables you to edit the kernel (of the DVD-loaded version of Linux)
Type "linux nohz-off nolapic text". (I needed the "text" instruction, because my
screen went crazy)

Result: anaconde comes to life in text mode. 

I selected Upgrade from F7. It took 1 hr, and the thing was done.

How I knew the commands? I just pasted together some info from here and there on
de internet.
Comment 4 Armijn Hemel 2008-01-20 14:01:54 EST
I tried this, but unfortunately it doesn't work for me :(
Comment 5 rh 2008-02-02 17:17:17 EST
I have the same problem on a HP Compaq nx6110.  Neither of the solutions help me.
Comment 6 rh 2008-02-03 06:57:40 EST
On the web somewhere I found this solution that helped: In the boot menu (with
the light blue picture) press tab and append floppy.allowed_drive_mask=0
clocksource=acpi_pm after vmlinuz etc
Comment 7 Armijn Hemel 2008-02-06 08:12:59 EST
I tested with the Fedora 9 Alpha rescue CD, without any of the work arounds
posted here, but still no luck.
Comment 8 Bug Zapper 2008-11-26 03:59:31 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Armijn Hemel 2008-12-08 06:04:13 EST
Closing, since I've been happily running Fedora 9 now for quite a long while.

Note You need to log in before you can comment on or make changes to this bug.