Bug 424081 - Fedora Everything repo contains invalid .treeinfo
Fedora Everything repo contains invalid .treeinfo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
http://download.fedora.redhat.com/pub...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 15:34 EST by James Laska
Modified: 2014-03-16 23:11 EDT (History)
5 users (show)

See Also:
Fixed In Version: F-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-22 07:51:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2007-12-13 15:34:28 EST
Description of problem:

Both Fedora/7 and Fedora/8 include the new .treeinfo descriptive file.  The
.treeinfo file is required by SNAKE to properly digest the installation source.
 It points to key files created by the compose (stage#2 images, boot media).  

There appears to be a .treeinfo file provided by the fedora Everything repo,
unfortunately, the file contents do not match the repo.  Additionally, I don't
believe the Fedora Everything repo was intended to be installable (e.g. no boot
media images/*).

Examples ... 

 *
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/.treeinfo
 *
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/x86_64/os/.treeinfo

Would it be possible to remove or update the .treeinfo file in the Everything repo

Version-Release number of selected component (if applicable):

Fedora/7 and Fedora/8

Actual results:

# curl
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/.treeinfo
[general]
family = Fedora
timestamp = 1193822224.97
variant = 
totaldiscs = 1
version = development
discnum = 1
packagedir = Packages
arch = i386

[images-i386]
kernel = images/pxeboot/vmlinuz
initrd = images/pxeboot/initrd.img
boot.iso = images/boot.iso
diskboot.img = images/diskboot.img

[images-xen]
kernel = images/xen/vmlinuz
initrd = images/xen/initrd.img

[stage2]
instimage = images/minstg2.img
mainimage = images/stage2.img

Expected results:

# curl
http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Everything/i386/os/.treeinfo
[general]
family = Fedora
timestamp = 1193822224.97
variant = Everything 
version = 8
packagedir = Packages
arch = i386

Additional info:

 * jkeating directed me to two scripts that are used to generate the Everything
repo.
   > scripts/buildrawhide -
http://git.fedoraproject.org/?p=fedora/releng;a=blob_plain;f=scripts/buildrawhide;hb=HEAD
   > scripts/pungify -
http://git.fedoraproject.org/?p=fedora/releng;a=blob_plain;f=scripts/pungify;hb=HEAD
Comment 1 Jesse Keating 2007-12-13 15:48:21 EST
It takes extreme needs to modify a release tree, and in my opinion this doesn't
count.  We can prevent the problem from happening in future trees but I'm not
going to modify the existing trees.
Comment 2 James Laska 2007-12-13 16:29:22 EST
jkeating: sorry, I should have been clearer ... this bug wasn't intended to
address existing trees

This was meant to track whatever fixes would be required to address this for >= F9
Comment 3 John Poelstra 2007-12-13 19:34:13 EST
Reopening to track >= F9
Comment 4 Bug Zapper 2008-05-14 00:11:50 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.