Bug 42410 - access.conf is not ignored if it contains valid/invalid directives
access.conf is not ignored if it contains valid/invalid directives
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-27 01:16 EDT by Henri Schlereth
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-27 01:16:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henri Schlereth 2001-05-27 01:16:01 EDT
Description of Problem:
During the process of trouble shooting a virtual hosting problem I put access data in access.conf and
uncommented the location in /etc/httpd/conf/httpd.conf. When the test failed I re-commented out
access. conf and resatarted apache. It still read the data in the access.conf

How Reproducible:
Do something like I did.

Steps to Reproduce:
1. leave access.conf commented out in httpd.conf
2. enter any access directive in access.conf (e.g virtual hosting directives or user access) 
Best way is to put something invalid to see it cough up an error message.
3. restart httpd

Actual Results:
access.conf is read despite being commented out

Expected Results:
directives in access.conf should be ignore as access.conf is commented out

Additional Information:
I was originally researching why the virtual hosting stuff wasnt working. I have followed the documented
stuff in the apache manual and even downloaded the full blown version of linuxconf to set this up.
Both of us cant be wrong. But I better bugzilla this separately.
Comment 1 Nalin Dahyabhai 2001-07-24 16:16:47 EDT
This is the documented default behavior of Apache (see
/var/www/html/manual/mod/core.html#accessconfig for more detail).

Essentially, if no access configuration file is specified, it will read and
parse access.conf.  The default access.conf includes a note that it should not
be modified, and httpd.conf includes a note that disabling this behavior
requires setting the paths for these files to /dev/null.

Tagging as not a bug.

Note You need to log in before you can comment on or make changes to this bug.