Bug 424311 - smime_keys perl script should glob tilde
smime_keys perl script should glob tilde
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 16:27 EST by Fabrice Bellet
Modified: 2008-06-25 05:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-25 05:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabrice Bellet 2007-12-13 16:27:05 EST
smime_keys calls 'mutt -Q' to obtain smime related paths. The problem is that
mutt returns paths containing '~' for the home directory. So the smime_keys
script should certainly glob() the answer before returning it :

--- /usr/bin/smime_keys 2007-11-23 13:02:04.000000000 +0100
+++ /home/bellet/bin/smime_keys 2007-12-13 21:51:59.000000000 +0100
@@ -20,6 +20,7 @@
 
 use strict;
 use File::Copy;
+use File::Glob ':glob';
 
 umask 077;
 
@@ -225,7 +226,7 @@
 EOF
 #'
 
-    $answer =~ /\"(.*?)\"/ and return $1;
+    $answer =~ /\"(.*?)\"/ and return bsd_glob($1, GLOB_TILDE);
     
     $answer =~ /^Mutt (.*?) / and die<<EOF;
 This script requires mutt 1.5.0 or later. You are using mutt $1.
Comment 1 Miroslav Lichvar 2008-01-25 08:07:34 EST
Reported upstream at http://dev.mutt.org/trac/ticket/3020.
Comment 2 Fedora Update System 2008-05-19 07:20:10 EDT
mutt-1.5.18-1.fc8 has been submitted as an update for Fedora 8
Comment 3 Fedora Update System 2008-05-21 07:09:35 EDT
mutt-1.5.18-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mutt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-4297

Note You need to log in before you can comment on or make changes to this bug.