Bug 424621 - *** PULSEAUDIO: Unable to connect: Connection refused
*** PULSEAUDIO: Unable to connect: Connection refused
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 00:17 EST by Parag Nemade
Modified: 2008-02-28 22:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 22:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio -vvv output (4.86 KB, application/octet-stream)
2008-02-21 06:37 EST, Parag Nemade
no flags Details

  None (edit)
Description Parag Nemade 2007-12-14 00:17:41 EST
Description of problem:
sometimes sound does not played as root user and some times it never plays as
root or any other user.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.17.svn20071017.fc8

How reproducible:
sometimes I successfully see this problem and sometimes not dunno what
parameters should I use to decide.

Steps to Reproduce:
1. open gnome-terminal as root or as normal user.
2. give command aplay <any sound file name>
3.
  
Actual results:
*** PULSEAUDIO: Unable to connect: Connection refused
aplay: main:546: audio open error: Connection refused


Expected results:
It should play sound.

Additional info:
other rpms installed are
alsa-oss-1.0.14-3.fc8
alsa-plugins-jack-1.0.14-5.fc8
alsa-plugins-samplerate-1.0.14-5.fc8
alsa-utils-1.0.15-1.fc8
alsa-oss-libs-1.0.14-3.fc8
alsamixergui-0.9.0-0.3.rc1.fc8.2
alsa-plugins-oss-1.0.14-5.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
alsa-lib-1.0.15-1.fc8
alsa-lib-devel-1.0.15-1.fc8
alsa-oss-devel-1.0.14-3.fc8
alsa-plugins-upmix-1.0.14-5.fc8
alsa-tools-1.0.12-4.fc7
alsa-plugins-vdownmix-1.0.14-5.fc8
akode-pulseaudio-2.0.1-9.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
Comment 2 Parag Nemade 2007-12-14 00:27:56 EST
additionally,
getfacl /dev/dsp =>
getfacl: Removing leading '/' from absolute path names
# file: dev/dsp
# owner: root
# group: root
user::rw-
user:gdm:rw-
user:parag:rw-
group::rw-
mask::rw-
other::---

Comment 3 Lubomir Kundrak 2007-12-20 06:04:44 EST
Parag: It seems like your sound server died. When this happens, please look for
messages from the pulseaudio daemon in /var/log/messages.

If this happens regularly, you may replace the pulseaudio server daemon with
server run in the terminal session and with increased verbosity. To do this,
kill your running server (pulseaudio -k) and run another one in termianal
(pulseaudio -vvv).
Comment 4 Parag Nemade 2007-12-20 22:51:01 EST
Thanks for your reply.
will do what you said and report further here when I will come across described
problem here.
Comment 5 cocobear 2008-01-07 06:29:19 EST
It happened often when I first install F8, when I change the default sound ouput to "auto detect" , It 
won't happen again.


[cocobear@cocobear disk]$ ls -l /dev/snd/*
crw-rw----+ 1 root root 116, 9 01-07 18:42 /dev/snd/controlC0
crw-rw----+ 1 root root 116, 4 01-07 18:42 /dev/snd/midiC0D0
crw-rw----+ 1 root root 116, 8 01-07 18:42 /dev/snd/pcmC0D0c
crw-rw----+ 1 root root 116, 7 01-07 18:42 /dev/snd/pcmC0D0p
crw-rw----+ 1 root root 116, 6 01-07 18:42 /dev/snd/pcmC0D1p
crw-rw----+ 1 root root 116, 5 01-07 18:42 /dev/snd/pcmC0D2p
crw-rw----+ 1 root root 116, 3 01-07 18:42 /dev/snd/seq
crw-rw----+ 1 root root 116, 2 01-07 18:42 /dev/snd/timer
[cocobear@cocobear disk]$ rpm -q kernel
kernel-2.6.23.8-63.fc8 
kernel-2.6.23.9-85.fc8   /*I am using this.*/


[cocobear@cocobear bash]$ sudo grep pulseaudio /var/log/messages 

Dec  3 13:20:32 cocobear pulseaudio[9727]: pid.c: Stale PID file, overwriting.
Dec  3 18:16:33 cocobear pulseaudio[2057]: pid.c: Stale PID file, overwriting.
Dec  3 20:09:24 cocobear pulseaudio[11474]: pid.c: Stale PID file, overwriting.
Dec  3 21:49:29 cocobear pulseaudio[2063]: pid.c: Stale PID file, overwriting.
Dec  3 21:49:30 cocobear pulseaudio[2063]: module-alsa-sink.c: Error opening PCM device hw:0: 没有那
个设备
Dec  3 21:49:30 cocobear pulseaudio[2063]: module.c: Failed to load  module "module-alsa-
sink" (argument: "device=hw:0 sink_name=alsa_output.pci_1013_6003_alsa_playback_0"): initialization 
failed.
Dec  3 21:49:30 cocobear pulseaudio[2063]: module-alsa-source.c: Error opening PCM device hw:0: 没有
那个设备
Dec  3 21:49:30 cocobear pulseaudio[2063]: module.c: Failed to load  module "module-alsa-
source" (argument: "device=hw:0 source_name=alsa_input.pci_1013_6003_alsa_capture_0"): 
initialization failed.
Dec  3 23:35:27 cocobear pulseaudio[2063]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  4 11:22:01 cocobear pulseaudio[3668]: pid.c: Stale PID file, overwriting.
Dec  4 15:35:04 cocobear pulseaudio[2649]: pid.c: Stale PID file, overwriting.
Dec  4 17:11:07 cocobear pulseaudio[2649]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  4 17:40:01 cocobear pulseaudio[2354]: pid.c: Stale PID file, overwriting.
Dec  4 23:52:17 cocobear pulseaudio[2354]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  5 23:45:46 cocobear pulseaudio[2015]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  6 19:56:15 cocobear pulseaudio[2017]: pid.c: Stale PID file, overwriting.
Dec  6 20:30:29 cocobear pulseaudio[2907]: pid.c: Stale PID file, overwriting.
Dec  7 00:24:50 cocobear pulseaudio[2907]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  7 09:39:31 cocobear pulseaudio[2020]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  7 13:08:49 cocobear pulseaudio[2667]: pid.c: Stale PID file, overwriting.
Dec  7 13:10:36 cocobear pulseaudio[3025]: pid.c: Stale PID file, overwriting.
Dec  7 14:07:20 cocobear pulseaudio[3025]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  8 23:29:58 cocobear pulseaudio[2018]: pid.c: Daemon already running.
Dec  8 23:29:58 cocobear pulseaudio[2018]: main.c: pa_pid_file_create() failed.
Dec  8 23:34:59 cocobear pulseaudio[2000]: pid.c: Stale PID file, overwriting.
Dec  9 00:00:15 cocobear pulseaudio[2000]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec  9 23:44:40 cocobear pulseaudio[2011]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 11 23:44:11 cocobear pulseaudio[2020]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 13 23:44:08 cocobear pulseaudio[1935]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 19 20:46:57 cocobear pulseaudio[2338]: pid.c: Daemon already running.
Dec 19 20:46:57 cocobear pulseaudio[2338]: main.c: pa_pid_file_create() failed.
Dec 20 12:27:25 cocobear pulseaudio[1946]: pid.c: Daemon already running.
Dec 20 12:27:25 cocobear pulseaudio[1946]: main.c: pa_pid_file_create() failed.
Dec 21 12:31:58 cocobear pulseaudio[1947]: pid.c: Stale PID file, overwriting.
Dec 21 14:06:57 cocobear pulseaudio[1947]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 21 23:55:08 cocobear pulseaudio[1952]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 23 14:20:16 cocobear pulseaudio[1947]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 24 23:53:50 cocobear pulseaudio[1940]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 27 15:20:06 cocobear pulseaudio[1940]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 27 23:24:40 cocobear pulseaudio[1945]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 28 13:20:07 cocobear pulseaudio[1958]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 30 00:02:42 cocobear pulseaudio[1958]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 31 17:58:45 cocobear pulseaudio[1957]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Dec 31 22:38:28 cocobear pulseaudio[1974]: pid.c: Daemon already running.
Dec 31 22:38:28 cocobear pulseaudio[1974]: main.c: pa_pid_file_create() failed.
Jan  1 10:22:53 cocobear pulseaudio[1982]: pid.c: Stale PID file, overwriting.
Jan  1 16:01:38 cocobear pulseaudio[1982]: module-volume-restore.c: failed to open file '(null)': 没有那个
文件或目录
Jan  3 00:12:27 cocobear pulseaudio[1984]: module-volume-restore.c: failed to open file '(null)': 没有那个
文件或目录
Jan  3 11:58:21 cocobear pulseaudio[1988]: module-volume-restore.c: failed to open file '(null)': 没有那个
文件或目录
Jan  3 20:09:49 cocobear pulseaudio[2293]: pid.c: Stale PID file, overwriting.
Jan  3 23:32:42 cocobear pulseaudio[2293]: module-volume-restore.c: failed to open file '(null)': 没有那个
文件或目录
Jan  4 09:50:10 cocobear pulseaudio[4151]: pid.c: Stale PID file, overwriting.
Jan  4 11:46:52 cocobear pulseaudio[1978]: pid.c: Stale PID file, overwriting.
Jan  5 19:29:57 cocobear pulseaudio[1956]: module-alsa-sink.c: Error opening PCM device hw:0: 没有那
个设备
Jan  5 19:29:57 cocobear pulseaudio[1956]: module.c: Failed to load  module "module-alsa-
sink" (argument: "device=hw:0 sink_name=alsa_output.pci_1013_6003_alsa_playback_0"): initialization 
failed.
Jan  5 19:29:57 cocobear pulseaudio[1956]: module-alsa-source.c: Error opening PCM device hw:0: 没有
那个设备
Jan  5 19:29:57 cocobear pulseaudio[1956]: module.c: Failed to load  module "module-alsa-
source" (argument: "device=hw:0 source_name=alsa_input.pci_1013_6003_alsa_capture_0"): 
initialization failed.
Jan  5 19:37:06 cocobear pulseaudio[1975]: pid.c: Stale PID file, overwriting.
Jan  5 20:06:30 cocobear pulseaudio[1980]: pid.c: Stale PID file, overwriting.
Jan  6 00:08:44 cocobear pulseaudio[1980]: module-volume-restore.c: failed to open file '(null)': 没有那个
文件或目录
Jan  6 23:35:53 cocobear pulseaudio[2038]: module-volume-restore.c: failed to open file '(null)': 没有那个
文件或目录
Jan  7 13:27:58 cocobear pulseaudio[4795]: pid.c: Stale PID file, overwriting.
Jan  7 16:43:55 cocobear pulseaudio[4795]: module-volume-restore.c: failed to open file '(null)': 没有那
个文件或目录
Comment 6 Parag Nemade 2008-01-07 06:38:20 EST
>It happened often when I first install F8, when I change the default sound
ouput to "auto detect" , It 
won't happen again.

And how you change it to "auto detect" ?
Comment 7 cocobear 2008-01-07 06:49:24 EST
System->Preference->hardware->sound effect.


Comment 8 Lubomir Kundrak 2008-01-07 06:54:13 EST
cocobear: could you please paste output of "/sbin/lsmod |grep snd"?
Seems like you might be facing the bug #370821 problem.
Also, could you please add output of "ck-list-sessions"?
Thanks.
Comment 9 cocobear 2008-01-07 07:00:40 EST
Here:
[cocobear@cocobear disk]$ lsmod | grep snd
snd_usb_audio          75329  0 
snd_usb_lib            17345  1 snd_usb_audio
snd_hwdep              10309  1 snd_usb_audio
snd_cs46xx             77609  4 
gameport               14665  2 snd_cs46xx
snd_rawmidi            21185  2 snd_usb_lib,snd_cs46xx
snd_ac97_codec         92389  1 snd_cs46xx
ac97_bus                6081  1 snd_ac97_codec
snd_seq_dummy           6725  0 
snd_seq_oss            29889  0 
snd_seq_midi_event      9793  1 snd_seq_oss
snd_seq                44849  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         10061  4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37569  0 
snd_mixer_oss          16705  2 snd_pcm_oss
snd_pcm                63685  4 snd_usb_audio,snd_cs46xx,snd_ac97_codec,snd_pcm_oss
snd_timer              20549  2 snd_seq,snd_pcm
snd                    43461  18 
snd_usb_audio,snd_hwdep,snd_cs46xx,snd_rawmidi,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9633  2 snd
snd_page_alloc         11337  2 snd_cs46xx,snd_pcm

[cocobear@cocobear disk]$ ck-list-sessions 
Session1:
        uid = '500'
        realname = ''
        seat = 'Seat1'
        session-type = ''
        active = TRUE
        x11-display = ':0'
        x11-display-device = '/dev/tty7'
        display-device = ''
        remote-host-name = ''
        is-local = TRUE
        on-since = '2008-01-07T10:44:05Z'

Comment 10 Lubomir Kundrak 2008-01-08 03:12:43 EST
Thanks, cocobear. To see if you hit the same problem, could you please skim
through bug #370821? Specifically check the following:

1.) HAL, ConsoleKit are running
# service ConsoleKit status
# service haldaemon status

2.) Your device symlinks are present
# ls -lR /sys/class/sound

3.) HAL recognizes the device correctly
# lshal |grep ^udi |grep alsa
# cat /var/lib/hal/acl-list
Comment 11 cocobear 2008-01-08 09:22:03 EST
[cocobear@cocobear ~]$ service ConsoleKit status
console-kit-daemon (pid 1566) 正在运行...
[cocobear@cocobear ~]$ service haldaemon status
hald (pid 1645) 正在运行...
[cocobear@cocobear ~]$ ls -lR /sys/class/sound/
/sys/class/sound/:
总计 0
drwxr-xr-x 3 root root 0 01-08 22:11 adsp
drwxr-xr-x 3 root root 0 01-08 22:11 audio
drwxr-xr-x 3 root root 0 01-08 22:11 controlC0
drwxr-xr-x 3 root root 0 01-08 22:11 dmmidi
drwxr-xr-x 3 root root 0 01-08 22:11 dsp
drwxr-xr-x 3 root root 0 01-08 22:11 midi
drwxr-xr-x 3 root root 0 01-08 22:11 midiC0D0
drwxr-xr-x 3 root root 0 01-08 22:11 mixer
drwxr-xr-x 3 root root 0 01-08 22:11 pcmC0D0c
drwxr-xr-x 3 root root 0 01-08 22:11 pcmC0D0p
drwxr-xr-x 3 root root 0 01-08 22:11 pcmC0D1p
drwxr-xr-x 3 root root 0 01-08 22:11 pcmC0D2p
drwxr-xr-x 3 root root 0 01-08 22:11 seq
drwxr-xr-x 3 root root 0 01-08 22:11 sequencer
drwxr-xr-x 3 root root 0 01-08 22:11 sequencer2
drwxr-xr-x 3 root root 0 01-08 22:11 timer

/sys/class/sound/adsp:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/adsp/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/audio:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/audio/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/controlC0:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/controlC0/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/dmmidi:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/dmmidi/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/dsp:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/dsp/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/midi:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/midi/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/midiC0D0:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/midiC0D0/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/mixer:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/mixer/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/pcmC0D0c:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
-r--r--r-- 1 root root 4096 01-08 22:11 pcm_class
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/pcmC0D0c/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/pcmC0D0p:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
-r--r--r-- 1 root root 4096 01-08 22:11 pcm_class
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/pcmC0D0p/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/pcmC0D1p:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
-r--r--r-- 1 root root 4096 01-08 22:11 pcm_class
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/pcmC0D1p/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/pcmC0D2p:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
lrwxrwxrwx 1 root root    0 01-08 22:11 device -> ../../../devices/pci0000:00/0000:00:05.0
-r--r--r-- 1 root root 4096 01-08 22:11 pcm_class
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/pcmC0D2p/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/seq:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/seq/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/sequencer:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/sequencer/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/sequencer2:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/sequencer2/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup

/sys/class/sound/timer:
总计 0
-r--r--r-- 1 root root 4096 01-08 22:11 dev
drwxr-xr-x 2 root root    0 01-08 22:11 power
lrwxrwxrwx 1 root root    0 01-08 22:11 subsystem -> ../../../class/sound
-rw-r--r-- 1 root root 4096 01-08 22:11 uevent

/sys/class/sound/timer/power:
总计 0
-rw-r--r-- 1 root root 4096 01-08 22:11 wakeup
[cocobear@cocobear ~]$ 

[cocobear@cocobear ~]$ lshal | grep ^udi | grep alsa
udi = '/org/freedesktop/Hal/devices/computer_alsa_timer'
udi = '/org/freedesktop/Hal/devices/computer_alsa_sequencer'
udi = '/org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_2'
udi = '/org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_1'
udi = '/org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_0'
udi = '/org/freedesktop/Hal/devices/pci_1013_6003_alsa_capture_0'
udi = '/org/freedesktop/Hal/devices/pci_1013_6003_alsa_midi_0'
udi = '/org/freedesktop/Hal/devices/pci_1013_6003_alsa_control__1'

[cocobear@cocobear ~]$ sudo cat /var/lib/hal/acl-list
/dev/adsp       /org/freedesktop/Hal/devices/pci_1013_6003_oss_pcm_1    u      42
/dev/adsp       /org/freedesktop/Hal/devices/pci_1013_6003_oss_pcm_1    u      500
/dev/audio      /org/freedesktop/Hal/devices/pci_1013_6003_oss_pcm_0    u      42
/dev/audio      /org/freedesktop/Hal/devices/pci_1013_6003_oss_pcm_0    u      500
/dev/dsp        /org/freedesktop/Hal/devices/pci_1013_6003_oss_pcm_0_0  u      42
/dev/dsp        /org/freedesktop/Hal/devices/pci_1013_6003_oss_pcm_0_0  u      500
/dev/midi       /org/freedesktop/Hal/devices/pci_1013_6003_oss_midi_0   u      42
/dev/midi       /org/freedesktop/Hal/devices/pci_1013_6003_oss_midi_0   u      500
/dev/mixer      /org/freedesktop/Hal/devices/pci_1013_6003_oss_mixer__1 u      42
/dev/mixer      /org/freedesktop/Hal/devices/pci_1013_6003_oss_mixer__1 u      500
/dev/sequencer  /org/freedesktop/Hal/devices/computer_oss_sequencer     u      42
/dev/sequencer  /org/freedesktop/Hal/devices/computer_oss_sequencer     u      500
/dev/sequencer2 /org/freedesktop/Hal/devices/computer_oss_sequencer_0   u      42
/dev/sequencer2 /org/freedesktop/Hal/devices/computer_oss_sequencer_0   u      500
/dev/snd/controlC0      /org/freedesktop/Hal/devices/pci_1013_6003_alsa_control__1      u       42
/dev/snd/controlC0      /org/freedesktop/Hal/devices/pci_1013_6003_alsa_control__1      u       500
/dev/snd/midiC0D0       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_midi_0 u42
/dev/snd/midiC0D0       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_midi_0 u500
/dev/snd/pcmC0D0c       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_capture_0       u       42
/dev/snd/pcmC0D0c       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_capture_0       u       500
/dev/snd/pcmC0D0p       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_0      u       42
/dev/snd/pcmC0D0p       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_0      u       500
/dev/snd/pcmC0D1p       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_1      u       42
/dev/snd/pcmC0D1p       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_1      u       500
/dev/snd/pcmC0D2p       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_2      u       42
/dev/snd/pcmC0D2p       /org/freedesktop/Hal/devices/pci_1013_6003_alsa_playback_2      u       500
/dev/snd/seq    /org/freedesktop/Hal/devices/computer_alsa_sequencer    u      42
/dev/snd/seq    /org/freedesktop/Hal/devices/computer_alsa_sequencer    u      500
/dev/snd/timer  /org/freedesktop/Hal/devices/computer_alsa_timer        u      42
/dev/snd/timer  /org/freedesktop/Hal/devices/computer_alsa_timer        u      500
/dev/sr0        /org/freedesktop/Hal/devices/storage_model_DVD_ROM_SD_C2302    u500
[cocobear@cocobear ~]$ 



*************************************************************************
I am not very sure why mplayer and other media players work well now. 
Comment 12 Parag Nemade 2008-02-21 06:01:20 EST
Is it possible to forcefully ask OS to drop references to /dev/dsp?
also, how can I solve this message on giving "pulseaudio -k" as user?
pulseaudio -k =>
--------------------------------------------------------------------------------
process 10670: dbus_shutdown() called but connections were still live. This
probably means the application did not drop all its references to bus connections.
  D-Bus not built with -rdynamic so unable to print a backtrace
Aborted
--------------------------------------------------------------------------------


Is there any solution for following problem?
Say I restored firefox profile with youtube link and I am already playing audio
say using mplayer application then once current song finishes mplayer failed to
play next audio file as firefox's youtube page tried to access sound.
resulting log of mplayer
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
*** PULSEAUDIO: Unable to connect: Connection refused
alsa-init: playback open error: Connection refused
[AO ESD] esd_open_sound failed: No such file or directory
[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16le
[AO SDL] Unable to open audio: No available audio device

any one can help here for this problem please?


Comment 13 Lubomir Kundrak 2008-02-21 06:17:57 EST
(In reply to comment #12)
> Is it possible to forcefully ask OS to drop references to /dev/dsp?

fuser -v /dev/dsp and kill all the processes you see?

> also, how can I solve this message on giving "pulseaudio -k" as user?
> pulseaudio -k =>
> --------------------------------------------------------------------------------
> process 10670: dbus_shutdown() called but connections were still live. This
> probably means the application did not drop all its references to bus connections.
>   D-Bus not built with -rdynamic so unable to print a backtrace
> Aborted

This is bug #427992

> 
> Is there any solution for following problem?
> Say I restored firefox profile with youtube link and I am already playing audio
> say using mplayer application then once current song finishes mplayer failed to
> play next audio file as firefox's youtube page tried to access sound.
> resulting log of mplayer

Do you have libflashsupport installed?

> [AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy

This is fair, you should not use OSS. See answer to first question to find out
what uses /dev/dsp.

> *** PULSEAUDIO: Unable to connect: Connection refused
> alsa-init: playback open error: Connection refused

This looks like pulseaudio is not running. Why did it die -- have you checked
/var/log/messages?

> any one can help here for this problem please?

Well, we can try :)
Comment 14 Parag Nemade 2008-02-21 06:33:23 EST
(In reply to comment #13)
> (In reply to comment #12)
> > Is it possible to forcefully ask OS to drop references to /dev/dsp?
> 
> fuser -v /dev/dsp and kill all the processes you see?
 nothing I see in output and still I am unable to play sound.

> 
> > also, how can I solve this message on giving "pulseaudio -k" as user?
> > pulseaudio -k =>
> > --------------------------------------------------------------------------------
> > process 10670: dbus_shutdown() called but connections were still live. This
> > probably means the application did not drop all its references to bus
connections.
> >   D-Bus not built with -rdynamic so unable to print a backtrace
> > Aborted
> 
> This is bug #427992
   Thanks for reference.

> 
> > 
> > Is there any solution for following problem?
> > Say I restored firefox profile with youtube link and I am already playing audio
> > say using mplayer application then once current song finishes mplayer failed to
> > play next audio file as firefox's youtube page tried to access sound.
> > resulting log of mplayer
> 
> Do you have libflashsupport installed?
  On rawhide, with Firefox3, I can see
      File name: libflashplayer.so
      Shockwave Flash 9.0 r31
> 
> > [AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
> 
> This is fair, you should not use OSS. See answer to first question to find out
> what uses /dev/dsp.
> 
> > *** PULSEAUDIO: Unable to connect: Connection refused
> > alsa-init: playback open error: Connection refused
> 
> This looks like pulseaudio is not running. Why did it die -- have you checked
> /var/log/messages?

  I see really really ugly logging output in /var/log/messages from ALSA like
ALSA sound/pci/hda/hda_intel.c:1272: azx_pcm_prepare: bufsize=0x4400,
fragsize=0x1100, format=0x4011
ALSA sound/pci/hda/hda_codec.c:686: hda_codec_setup_stream: NID=0x3, stream=0x1,
channel=0, format=0x4011
ALSA sound/pci/hda/hda_intel.c:1272: azx_pcm_prepare: bufsize=0x4400,
fragsize=0x1100, format=0x4011
ALSA sound/pci/hda/hda_codec.c:686: hda_codec_setup_stream: NID=0x3, stream=0x1,
channel=0, format=0x4011
ALSA sound/pci/hda/hda_codec.c:686: hda_codec_setup_stream: NID=0x3, stream=0x0,
channel=0, format=0x0
ALSA sound/pci/hda/hda_codec.c:686: hda_codec_setup_stream: NID=0x3, stream=0x0,
channel=0, format=0x0

> 
> > any one can help here for this problem please?
> 
> Well, we can try :)
Thanks for quick reply. But still no luck to play sound even after as user
"parag" starting "pusleaudio -vv", I see same error with mplayer. 

on one console I have running "pulseaudio -vv" and on another when tried to play
sound with mplayer, I see
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
*** PULSEAUDIO: Unable to create stream.
alsa-init: unable to set hw-parameters: Input/output error


Comment 15 Parag Nemade 2008-02-21 06:37:35 EST
Created attachment 295498 [details]
pulseaudio -vvv output

here is output on my current session of rawhide machine for command "pulseaudio
-vvv"
Comment 16 Parag Nemade 2008-02-26 00:29:01 EST
with yesterday rawhide update I am getting now
pulseaudio[4738]: segfault at d2fb ip 00b44aec sp bffca294 error 6 in
liboil-0.3.so.0.1.0[b21000+5f000]
pulseaudio[4785]: segfault at 2e9a ip 00b44aec sp bfa76ad4 error 6 in
liboil-0.3.so.0.1.0[b21000+5f000]
pulseaudio[5371]: segfault at 66b3 ip 00b44aec sp bfa2a774 error 6 in
liboil-0.3.so.0.1.0[b21000+5f000]


above are 3 attempts to start pulseaudio manually where I got
I: main.c: PolicyKit grants us acquire-high-priority privilige.
I: core-util.c: Successfully gained nice level -11.
W: pid.c: Stale PID file, overwriting.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
Segmentation fault

Comment 17 Lubomir Kundrak 2008-02-26 06:50:39 EST
Parag: please open a separate bug report. Please do "debuginfo-install
pulseaudio" (you need yum-utils for that) and, run:

$ gdb pulseaudio
(gdb) run -vvv
...
(gdb) bt
...

and please paste the output to the bug report.
Thanks!
Comment 18 Parag Nemade 2008-02-26 07:13:37 EST
Thanks. I got this solved as problem was actually with liboil package. I updated
new build from koji and sound starts working.
Reason behind posting problem here is that when I ran alsamixer, I saw same
error as summary of this bug.

But I am still holding this bug open as summary title error always used to occur
on rawhide. Overall pulseaudio is unstable and can't handle sound playing
functionality from various applications(mplayer,streaming videos in firefox etc.)

Also, either user need to give up e.g. either as root I can play sound or as
Parag I can play sound but not from both user(opened as root and opened as
parag) console terminals.


Comment 19 Lubomir Kundrak 2008-02-28 12:29:40 EST
I'm getting lost in this bug report.
Does it track any issues that still exist and are reproducible?
Comment 20 Parag Nemade 2008-02-28 22:53:41 EST
I come to know simple solution today. Just remove pulseaudio and old sound
system is working fine for me. Even as root and as parag user and even firefox
can play streaming audio now.

Resolving this as I got sound working now. But I am still confirm pulseaudio is
having many problems and not stable.

Thanks all for your help. Thanks Lubomir for your prompt reply.

Note You need to log in before you can comment on or make changes to this bug.