Bug 424681 - INTERFACE_MAX is not proper
INTERFACE_MAX is not proper
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: openais (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven Dake
:
: 424671 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 02:26 EST by Fabio Massimo Di Nitto
Modified: 2016-04-26 09:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 03:48:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabio Massimo Di Nitto 2007-12-14 02:26:26 EST
Description of problem:

exec/totem.h defines INTERFACE_MAX to 2. This is very limiting and it is not
coherent with the rest of the cluster stack.

openais limits to 2
kernel dlm to 3
dlm_controld to 4

Those values should be at least alligned to 4 or higher.

In theory a dynamic allocation here would be the winner.

with the default set to 2, configuring 3 rings in openais.conf (passive mode,
since active it totally broken), will lead openais to crash because of memory
corruption (there is no protection within the code to try to init and config
only INTERFACE_MAX).

Version-Release number of selected component (if applicable):

trunk

How reproducible:

always

Steps to Reproduce:
1. given default svn checkout
2. configure INTERFACE_MAX + 1 rings in passive mode
3. fire up aisexec.

(tested on amd64 with glibc-2.7 will report memory corruption detected by glibc)

Actual results:

aisexec crashes and dies.

Expected results:

should work no matter how many rings i configure. hardcoded limitations are bad
and it is not even documented.

Additional info:
Comment 1 Lon Hohberger 2008-01-03 14:37:17 EST
*** Bug 424671 has been marked as a duplicate of this bug. ***
Comment 2 Fabio Massimo Di Nitto 2008-01-04 04:01:28 EST
The cman crash has been fixed.

Time to address the inconsistency.

Fabio
Comment 3 Steven Dake 2008-01-15 03:48:41 EST
breaks compatability will not be changed in rhel5.
Comment 4 Fabio Massimo Di Nitto 2008-01-15 04:02:08 EST
It does not need to be fixed in rhel5 but can be done in trunk and forward releases.

Note You need to log in before you can comment on or make changes to this bug.