Bug 424691 - query screen slow down due to ajax
query screen slow down due to ajax
Status: CLOSED DUPLICATE of bug 457843
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.2
All Linux
low Severity low (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 02:38 EST by Kevin Baker
Modified: 2014-12-01 18:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-25 17:22:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to disable use of ajax on first page load if no form data present (4.29 KB, patch)
2007-12-14 12:56 EST, David Lawrence
no flags Details | Diff

  None (edit)
Description Kevin Baker 2007-12-14 02:38:52 EST
Description of problem:

When you first click on the 
https://bugzilla.redhat.com/query.cgi?format=simple page the page locks up 
while the ajax calls to load Versions/Components/Milstones complete. Even 
though there is no product intially selected. This is painful when I want to 
go to the simple page but then get to the Advanced page asap. 

I think it would be better for the user experience, and less stress full on 
system resources if it didn't call ajax to load the 
Version/Components/Milestones until a product is selected. After all, for 
which product is it loading these fields when no product is selected on the 
initial view? ditto for the advanced screen. So initially all the user sees is 
the product list to choose from.
Comment 1 David Lawrence 2007-12-14 10:20:10 EST
Currently this done at first load so that if any form values are passed in they
will be automatically selected such as product/component/version and that the
lists will look correct. This is critical for things like editing stored
queries, etc.

A fix would be to define a javascript variable that is true/false depending on
whether any form data was passed to the cgi. Then also had another var called 
firstrun that is set to 1 when the page first loads and then set to 0 once the
products have been updated once.

Then in the jscript code do check:

if ( formdata == 1 && firstrun == 0 ) {
    update select lists 
    set formdate = 0
    set firstrun = 0
} else {
    do nothing
}
Comment 2 David Lawrence 2007-12-14 10:21:00 EST
ooops should be:

if ( formdata == 1 || firstrun == 0 ) {
    update select lists 
    set formdata = 0
    set firstrun = 0
} else {
    do nothing
}

Comment 3 David Lawrence 2007-12-14 12:56:52 EST
Created attachment 289311 [details]
Patch to disable use of ajax on first page load if no form data present
Comment 4 David Lawrence 2008-09-16 12:55:40 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 5 David Lawrence 2008-11-25 17:22:42 EST
This is still issue even with the new revised ajax code.

*** This bug has been marked as a duplicate of bug 457843 ***

Note You need to log in before you can comment on or make changes to this bug.