Bug 42471 - aspell does not work with balsa - missing files in the package
aspell does not work with balsa - missing files in the package
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: aspell (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-27 11:03 EDT by Pawel Salek
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-29 13:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2001-05-27 11:03:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
aspell module does not work with balsa because dynamic library modules are
missing:

/usr/lib/libpspell_aspell.la
/usr/lib/libpspell_aspell.so.1.0.4

The original Makefile is broken, IMO.


How reproducible:
Always

Steps to Reproduce:
1. run balsa
2. compose new message
3. press spell-check button
	

Actual Results:  Error message 'Cannot load "aspell" module'.

Expected Results:  Display spell checking buttons.

Additional info:

The two following files should be added to aspell-0.32.6-2.i386.rpm in
order to make it work with balsa.

/usr/lib/libpspell_aspell.la
/usr/lib/libpspell_aspell.so.1.0.4
and a soft link
/usr/lib/libpspell_aspell.so.1 -> /usr/lib/libpspell_aspell.so.1.0.4

(I find it rewarding to analyze strace dump of balsa; pspell library
looks for the dynamically loaded libraries in several places, but the
locations above seem most sensible).

I think it is a bug in the original source because make install prints:

mv: cannot stat `libpspell_aspell.so.1.0.4': No such file or directory

The aspell author kevina@users.sourceforge.net should be informed.
Comment 1 Trond Eivind Glomsrxd 2001-05-29 13:00:58 EDT
Aspell is a pain to build - if it can't find the libraries it's building, it
just continues to build as if nothing happened. At it doesn't find the libraries
it builds without manually adding the build directories to the compilation
flags... I'll look into it.
Comment 2 Trond Eivind Glomsrxd 2001-05-29 19:02:49 EDT
It was a bug in libtool - the issue should be fixed in aspell-0.33.6-2, which
comes with its own, fixed ltmain.sh
Comment 3 Pawel Salek 2001-07-10 04:40:58 EDT
I have just checked aspell-0.33.6.3-1 from rawhide and it still does not
include /usr/lib/libpspell_aspell.la that is needed by pspell to load 
libpspell_aspell.so dynamically. So this problem is only half-resolved.

Note You need to log in before you can comment on or make changes to this bug.