Bug 424731 - error and debug levels in yum shell do not respect -e/-d options
error and debug levels in yum shell do not respect -e/-d options
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 03:10 EST by Jan Hutař
Modified: 2009-03-25 01:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 01:32:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2007-12-14 03:10:57 EST
Description of problem:
While creating yum test I have noticed that yum did not shows correct values of 
error and debug levels set with -e/-d option in the yum shell.


Version-Release number of selected component (if applicable):
3.2.8-2.fc8
3.0.1-5.el5


How reproducible:
always


Steps to Reproduce:
[root@pok ~]# yum -d0 shell
> config debuglevel

[root@pok ~]# yum -d1 shell
> config debuglevel

[root@pok ~]# yum -d2 shell
Loading "refresh-updatesd" plugin
Loading "skip-broken" plugin
Setting up Yum Shell
> config debuglevel
debuglevel: 2

[root@pok ~]# yum -d3 shell
Loading "refresh-updatesd" plugin
Loading "skip-broken" plugin
Running "config" handler for "skip-broken" plugin
Yum Version: 3.2.8
COMMAND: yum -d3 shell 
Installroot: /
No argument to shell
Setting up Yum Shell
> config debuglevel
debuglevel: 3

[root@pok ~]# yum -d100 shell
Loading "refresh-updatesd" plugin
Loading "skip-broken" plugin
Running "config" handler for "skip-broken" plugin
Yum Version: 3.2.8
COMMAND: yum -d100 shell 
Installroot: /
No argument to shell
Setting up Yum Shell
> config debuglevel
debuglevel: 100

  
Actual results:
# yum -d1 shell
> config debuglevel
<no output>


Expected results:
# yum -d1 shell
> config debuglevel
debuglevel: 1


Additional info:
This seems really low priority, mostly I'm only curious if it is a bug or a 
feature.

It is similar with "-e" option and "config errorlevel", but this seems to be 
fixed in F8 and broken in RHEL5:

--- RHEL5 3.0.1-5.el5 ---

# yum -e1 shell
Loading "refresh-updatesd" plugin
Loading "skip-broken" plugin
Setting up Yum Shell
> config errorlevel
errorlevel: 1

--- F8 3.2.8-2.fc8 ---

# yum -e1 shell
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
> config errorlevel
errorlevel: 2

Note You need to log in before you can comment on or make changes to this bug.