Bug 42474 - Bad: Installer crashed after a pop-up appeared complaining about /usr partition not large enough by 113 megs.
Bad: Installer crashed after a pop-up appeared complaining about /usr partiti...
Status: CLOSED DUPLICATE of bug 38448
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-27 13:38 EDT by Rich Passmore
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 09:21:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The bug report dump as written by the installation. (898 bytes, text/plain)
2001-05-27 13:39 EDT, Rich Passmore
no flags Details

  None (edit)
Description Rich Passmore 2001-05-27 13:38:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows 98; Win 9x 4.90)

Description of problem:
Bad: I was using a previous disk overlay from the Fisher Beta and 
reformatted all partitions.  When the install started, a pop-up appeared 
and stated something to the effect "Not enough space for install on /usr.  
Space needed 164M"  After hitting OK, the system popped up a bug report 
and I wrote it to floppy.

How reproducible:
Couldn't Reproduce

Steps to Reproduce:


Additional info:

Target system is a Dell Inspiron 5000e P3-750 with 256 megs of RAM and ATI 
Rage Mobility 128w/16 megs of RAM.
1. Select Disk Druid for install.
2. 20 gig hard drive with the following partitions:
Mount Point  Device  Requested  Actual  Type
/mnt/win     hda1    15607M     15607M  Win95  FAT32
/boot        hda5    22M        22M     Linux native
<Swap>       hda6    516M       516M    Linux Swap
/            hda7    1387M      1387M   Linux native
/tmp         hda8    516M       516M    Linux native
/usr         hda9    1026M      1026M   Linux native
3.  Next get a pop-up about the partition containing the kernel is above 
the 1024 cylinder limit.  It appears that this systems BIOS supports 
booting from above this limit.  (I've never had a problem booting from 
above the 1024 cyl limit).

Results from anacdump.txt:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1925, in 
doInstall
    self.fstab.umountFilesystems(self.instPath)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 632, in 
umountFilesystems
    isys.umount(mntPoint, removeDir = 0)
  
File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys
.py", line 134, in umount
    raise ValueError, "isys.umount() can only umount by mount point"
ValueError: isys.umount() can only umount by mount point

Local variables in innermost frame:
what: /mnt/sysimage/mnt./win
removeDir: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I521
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>
Comment 1 Rich Passmore 2001-05-27 13:39:15 EDT
Created attachment 19750 [details]
The bug report dump as written by the installation.
Comment 2 Brent Fox 2001-05-29 14:00:17 EDT
Did you make a mount point for your FAT partition?
Comment 3 Rich Passmore 2001-06-07 09:21:47 EDT
I did create a mount point for my FAT partition and called it /mnt/win.  I have 
noticed in subsequent installations that the install crashes when I do this.
Comment 4 Brent Fox 2001-06-11 12:35:59 EDT
Yes, this is a known problem.  A workaround is to not set a mount point for the
FAT partition in the installer and add it to your /etc/fstab file later.

This is a dupe of bug #38448

*** This bug has been marked as a duplicate of 38448 ***
Comment 5 Brent Fox 2001-06-11 12:44:51 EDT
The strange thing is, though, I just tried this on my test machine, and it works
fine.  I can set mount points for the two Windows partitions and the install
finishes normally and I can access those partitions after rebooting.

Note You need to log in before you can comment on or make changes to this bug.