Bug 424811 - liveinst stops with: No module named firstboot_module_window
liveinst stops with: No module named firstboot_module_window
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
Depends On:
Blocks: KDE4Live
  Show dependency treegraph
 
Reported: 2007-12-14 05:12 EST by Sebastian Vahl
Modified: 2009-01-07 13:17 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.11-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 17:06:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Rework to support new firstboot module system (8.24 KB, text/plain)
2007-12-17 15:05 EST, Chris Lumens
no flags Details

  None (edit)
Description Sebastian Vahl 2007-12-14 05:12:36 EST
Description of problem:
When starting liveinst on a livecd it stops after you accept that this is a 
test release. 

The graphical error:

An error occurred when attempting to load an installer interface component
className = KeyboardWindow

The output in a terminal:

$ liveinst 
FATAL: Module md not found.
/usr/sbin/liveinst: line 40: /usr/sbin/swapoff: No such file or 
directory
  No volume groups found
Probing for video card:   nVidia Corporation NV17 [GeForce4 MX 440]
11:01:55 Starting graphical installation...
No module named firstboot_module_window


Version-Release number of selected component (if applicable):
anaconda-11.4.0.8-1

How reproducible:
ever

Steps to Reproduce:
1. create a livecd from current rawhide
2. boot the cd
3. start "liveinst" in a terminal
  
Actual results:
liveinst fails

Expected results:
liveinst works

Additional info:
It seems that after the initial start of liveinst my keyboard layout was set 
to german. The locale in the kickstart for the livecd was en_US.UTF-8. I 
haven't manually set this.
Comment 1 Sebastian Vahl 2007-12-14 05:20:47 EST
I've grabbed anaconda-11.4.0.9-1 from koji and updated it on a running livecd. 
Same error.
Comment 2 Jeremy Katz 2007-12-14 07:59:24 EST
This is due to the changes in system-config-keyboard.  Chris -- I thought you
had a fix for this.
Comment 3 Sebastian Vahl 2007-12-17 06:15:26 EST
The used version of system-config-keyboard is 1.2.11-3.fc8
Comment 4 Chris Lumens 2007-12-17 15:05:43 EST
Created attachment 289803 [details]
Rework to support new firstboot module system

Attached is a new version of keyboard_gui.py which should work with the new
firstboot in rawhide.  I've tested this briefly as a firstboot module and as a
stand-alone program, but I have not yet gotten a chance to test it with
anaconda due to no images today.  More testing would be appreciated.
Comment 5 Sebastian Vahl 2007-12-18 05:04:07 EST
I've copied the file into a running livecd into the normal place and started 
liveinst. The graphical error is the same, but in the terminal a new error is 
shown:

cannot import name KeyboardWindow


If I start anaconda directly with "anaconda --method=livecd" I'm seeing the 
keyboard selection. But when I select one and hit "next" the same error 
occurs.
anaconda-11.4.0.10-1


Comment 6 Jeremy Katz 2008-01-01 13:30:41 EST
svahl -- you also need a newer anaconda (.12)

But even with that, things don't quite work.  Unfortunately both firstboot and
anaconda have a module named 'constants' and both are just (ab)using the python
path to get their modules available.  Thus, you only get the anaconda constants
module and not the firstboot one. 

Given that firstboot is providing an API, it probably makes sense to have it
available as the 'firstboot' module and then it'd be firstboot.constants and
things would be happy.
Comment 7 Chris Lumens 2008-01-02 17:53:38 EST
firstboot has been updated and rebuilt in order to provide a real python module.
 This will require changing my new keyboard module above to not append
/usr/share/firstboot and also to import firstboot.whatever instead.
Comment 8 Chris Lumens 2008-01-23 11:55:20 EST
This should be fixed in today's rawhide.
Comment 9 Sebastian Vahl 2008-01-23 17:06:21 EST
(In reply to comment #8)
> This should be fixed in today's rawhide.

Confirmed. 

Fixed with system-config-keyboard-1.2.11-4.fc9 and anaconda-11.4.0.24-1.


Note You need to log in before you can comment on or make changes to this bug.