Bug 424911 - Kopete crashes when logging in msn & gtalk
Kopete crashes when logging in msn & gtalk
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 08:08 EST by Edward Karavakis
Modified: 2007-12-14 08:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 08:15:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 154027 None None None Never

  None (edit)
Description Edward Karavakis 2007-12-14 08:08:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc8 Firefox/2.0.0.10

Description of problem:
Version:           0.12.7 (using KDE KDE 3.5.8)
Installed from:    Fedora RPMs
OS:                Linux

Kopete on Fedora 8 crashes after logging in msn & gtalk
backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208355120 (LWP 12237)]
[KCrash handler]
#6  0x012c08b9 in operator== (s1=@0x750037, s2=@0xbfcdf460)
    at tools/qstring.h:653
#7  0x080b1869 in QValueListPrivate<QString>::contains (this=0x9c0e6c8,
    x=@0xbfcdf460) at /usr/lib/qt-3.3/include/qvaluelist.h:346
#8  0x01a91630 in KopeteEmoticonAction (this=0xb5629070, parent=0xb58f3f60,
    name=0x1a9a09c "format_smiley")
    at /usr/lib/qt-3.3/include/qvaluelist.h:545
#9  0x01a77b6b in KopeteChatWindow::initActions (this=0xb58f6a70)
    at kopetechatwindow.cpp:385
#10 0x01a78c62 in KopeteChatWindow (this=0xb58f6a70, parent=0x0,
    name=0x1a998e9 "KopeteChatWindow") at kopetechatwindow.cpp:176
#11 0x01a792ea in KopeteChatWindow::window (manager=0xb583ee28)
    at kopetechatwindow.cpp:150
#12 0x01a7cd13 in ChatView::makeVisible (this=0xb586eba8) at chatview.cpp:311
#13 0x01a708c6 in ChatView::raise (this=0xb586eba8, activate=true)
    at chatview.cpp:276
#14 0x001ae824 in Kopete::Contact::execute () from /usr/lib/libkopete.so.1
#15 0x001d3e93 in Kopete::MetaContact::execute () from /usr/lib/libkopete.so.1
#16 0x080b25f2 in KopeteMetaContactLVI::execute (this=0xb6ed3ce0)
    at kopetemetacontactlvi.cpp:491
#17 0x080879fb in KopeteContactListView::slotExecuted (this=0x9b04bf8,
    item=0xb6ed3d08, p=@0xbfce00d8) at kopetecontactlistview.cpp:825
#18 0x08091d42 in KopeteContactListView::qt_invoke (this=0x9b04bf8, _id=121,
    _o=0xbfcdff9c) at kopetecontactlistview.moc:231
#19 0x00fa3b8a in QObject::activate_signal (this=0x9b04bf8, clist=0x9b0b560,
    o=0xbfcdff9c) at kernel/qobject.cpp:2356
#20 0x0089461b in KListView::executed (this=0x9b04bf8, t0=0xb6ed3d08,
    t1=@0xbfce00d8, t2=0) at klistview.moc:360
#21 0x00894aef in KListView::emitExecute (this=0x9b04bf8, item=0xb6ed3d08,
    pos=@0xbfce00d8, c=0) at klistview.cpp:702
#22 0x00894c85 in KListView::contentsMouseDoubleClickEvent (this=0x9b04bf8,
    e=0xbfce00c4) at klistview.cpp:899
#23 0x010d4571 in QScrollView::viewportMouseDoubleClickEvent (this=0x9b04bf8,
    e=0xbfce05c0) at widgets/qscrollview.cpp:1764
#24 0x010d2111 in QScrollView::eventFilter (this=0x9b04bf8, obj=0x9b05510,
    e=0xbfce05c0) at widgets/qscrollview.cpp:1506
#25 0x0109b1f6 in QListView::eventFilter (this=0x9b04bf8, o=0x9b05510,
    e=0xbfce05c0) at widgets/qlistview.cpp:3867
#26 0x00fa2f3c in QObject::activate_filters (this=0x9b05510, e=0xbfce05c0)
    at kernel/qobject.cpp:903
#27 0x00fa2fbb in QObject::event (this=0x9b05510, e=0xbfce05c0)
    at kernel/qobject.cpp:735
#28 0x00fdfe6c in QWidget::event (this=0x9b05510, e=0xbfce05c0)
    at kernel/qwidget.cpp:4678
#29 0x00f3a38b in QApplication::internalNotify (this=0xbfce0aa4,
    receiver=0x9b05510, e=0xbfce05c0) at kernel/qapplication.cpp:2635
#30 0x00f3bb39 in QApplication::notify (this=0xbfce0aa4, receiver=0x9b05510,
    e=0xbfce05c0) at kernel/qapplication.cpp:2421
#31 0x00beee82 in KApplication::notify (this=0xbfce0aa4, receiver=0x9b05510,
    event=0xbfce05c0) at kapplication.cpp:550
#32 0x00ed1266 in QETWidget::translateMouseEvent (this=0x9b05510,
    event=0xbfce0968) at kernel/qapplication.h:523
#33 0x00ed0036 in QApplication::x11ProcessEvent (this=0xbfce0aa4,
    event=0xbfce0968) at kernel/qapplication_x11.cpp:3600
#34 0x00ee1cbb in QEventLoop::processEvents (this=0x9a50ff8,
    flags=<value optimized out>) at kernel/qeventloop_x11.cpp:192
#35 0x00f53c60 in QEventLoop::enterLoop (this=0x9a50ff8)
    at kernel/qeventloop.cpp:198
#36 0x00f53b16 in QEventLoop::exec (this=0x9a50ff8)
    at kernel/qeventloop.cpp:145
#37 0x00f39fcf in QApplication::exec (this=0xbfce0aa4)
    at kernel/qapplication.cpp:2758
#38 0x0807ca9c in main (argc=) at main.cpp:107
#39 0x02bdd390 in __libc_start_main (main=0x807c320 <main>, argc=7,
    ubp_av=0xbfce0c44, init=0x80ba110 <__libc_csu_init>,
    fini=0x80ba100 <__libc_csu_fini>, rtld_fini=0x11e940 <_dl_fini>,
    stack_end=0xbfce0c3c) at libc-start.c:220
#40 0x0806c161 in _start () 

Version-Release number of selected component (if applicable):
kopete 0.12.7 kdenetwork-3.5.8-9

How reproducible:
Always


Steps to Reproduce:
1. launch application
2. log in to msn and/or gtalk
3. wait for a min

Actual Results:
Kopete crashes every single time I login to msn/gtalk

Expected Results:


Additional info:
Comment 1 Rex Dieter 2007-12-14 08:15:44 EST
Looks like you already reported it upstream,
http://bugs.kde.org/154027

Thanks, we'll continue to track the issue there.

Note You need to log in before you can comment on or make changes to this bug.