Bug 425021 - start wifi connection with WPA2_Personal and DHCP at boot
Summary: start wifi connection with WPA2_Personal and DHCP at boot
Status: CLOSED DUPLICATE of bug 244029
Alias: None
Product: Fedora
Classification: Fedora
Component: wpa_supplicant   
(Show other bugs)
Version: 8
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-14 15:00 UTC by Sergei LITVINENKO
Modified: 2007-12-24 22:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-24 22:34:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sergei LITVINENKO 2007-12-14 15:00:00 UTC
Description of problem:

Wrong order of starting services: network(10 90), wpa_supplicant(12 88),
messagebus(22 85) cause problem to start wifi connection at boot time if
wpa_supplicant is required.

Right order, as I understand, should be: messagebus(08 92), wpa_supplicant(09
91), network(10 90).

Version-Release number of selected component (if applicable):
wpa_supplicant-0.5.7-16.fc8
dbus-1.1.2-7.fc8
initscripts-8.60-1

How reproducible:
100%.

Steps to Reproduce:

1. Setup autorization on wifi access point (as example WPA2_Personal)
2. Setup autorization wifi connection by wpa_supplicant on Linux host
3. Setup wifi interface by /etc/sysconfig/network-scripts/ifcfg-xxxx as example
cat /etc/sysconfig/network-scripts/ifcfg-wlan0
DEVICE=wlan0
TYPE=Wireless
BOOTPROTO=dhcp
ONBOOT=yes
4. Reboot the system.

Actual results:
wifi interface can not receive IP address (timeout)
wpa_supplicant is stopped

Expected results:
wpa_supplicant is started
wifi interface have IP address by DHCP.

Additional info:

Comment 1 Bill Nottingham 2007-12-14 17:09:52 UTC
The initscripts are ordered according to the dependencies specified in them.

Comment 2 Oscar Valdez 2007-12-17 20:11:31 UTC
I've noticed the same since upgrading to Fedora 8. On Fedora 7, I could start
wpa_supplicant during boot, now on 8, I can't. The diff between the two init
scripts is as follows:

# diff /tmp/wpa_supplicant (f7) /etc/init.d/wpa_supplicant (f8)
21,23d20
< # Check that networking is up.
< [ "$NETWORKING" = "no" ] && exit 0
< 
30,31d26
< [ "$INTERFACES" != "" ] || exit 0
< [ "$DRIVERS" != "" ] || exit 0
34,35c29,30
<       echo -n $"Starting $prog: "
<       daemon $prog -c $conf $INTERFACES $DRIVERS -B
---
>       echo -n $"Starting $prog: $conf, $INTERFACES, $DRIVERS"
>       daemon $prog -c $conf $INTERFACES $DRIVERS -B -u -f


Comment 3 Oscar Valdez 2007-12-22 10:50:54 UTC
The error message when wpa_supplicant is started at boot is:

Iniciando wpa_supplicant: /etc/wpa_supplicant/wpa_supplicant.conf,
,dbus_bus_get[ctrl_iface_dbus]: No such file or directory.

(After /etc/wpa_supplicant/wpa_supplicant.conf, there is a comma, a space, and
another comma).

This did not occur with Fedora 7.

Said file has the following contents (key removed)

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

network={
        ssid="andunie"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP
        group=TKIP
        psk=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
}


Comment 4 Dan Williams 2007-12-24 22:34:03 UTC

*** This bug has been marked as a duplicate of 244029 ***


Note You need to log in before you can comment on or make changes to this bug.