Bug 42511 - rpm free list error message
Summary: rpm free list error message
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-27 23:06 UTC by jclama
Modified: 2007-04-18 16:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-11 22:00:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar ball of my database (deleted)
2001-05-29 22:09 UTC, jclama
no flags Details

Description jclama 2001-05-27 23:06:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-5.0 i586; en-US; 0.8)
Gecko/20010216

Description of problem:
I ran rpm --rebuilddb but nothing happened.
I read to do this in the mailing lists.
I append a tarball of my database
I was using Ximian gnome 1.4

How reproducible:
Always

Steps to Reproduce:
1.gnorpm
2.
3.
	

Additional info:

Comment 1 Jeff Johnson 2001-05-29 20:14:05 UTC
I still need a pointer to a tar ball of your database
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm

Comment 2 jclama 2001-05-29 22:14:17 UTC
I am trying to send, but only have a 56k modem, and my mozilla fails when Im 
doing it. When you say a 'pointer' you mean the tar file?, because it's 7 MB 
long. Can I send it by email to some direction you tell me?. I don't know if 
it's correct, because received an error message.

Comment 3 jclama 2001-05-29 22:19:02 UTC
Please, if the answer is going to be that big, send it to jclama@terra.es, or 
they'll throw me away from yahoo!,!. Thanks

Comment 4 Jeff Johnson 2001-05-30 12:50:17 UTC
A pointer is a URL that names the tarball. If you put the file someplace
where I can fetch, I will do so. Otherwise try mail to <jbj@redhat.com>

Comment 5 jclama 2001-06-11 22:00:47 UTC
Hello there! Did somebody receive the mail with the tarball?

Comment 6 Jeff Johnson 2001-06-15 04:46:54 UTC
Apologies for the delay. Your problem is fixed in rpm-4.0.3-0.38. I'll have a 
copy for 6.2 available on ftp.rpm.org in the next day or so.

Comment 7 jclama 2001-06-16 00:08:20 UTC
So, the solution is upgrade to 4.0.3-0.38, but we both know I can't use rpm on 
my system... so I understand I should use a tarball and overwrite my rpm 
install (tar -xcvf... and something more to force overwriting, "RTFM"), and, 
after that, I can rebuild my database (rpm --rebuilddb). 
1. Is this correct?
2. Can I blame Ximian Redcarpet, and use from now on only the Red Hat updater 
to be sure?

Comment 8 Jeff Johnson 2001-06-16 01:27:27 UTC
If it would help, I can mail you a fixed copy of your packages.rpm, drop
me a note <jbj@redhat.com> if you want me to do so.

No it's not entirely Ximian's fault, there's a number of pieces to this problem
some of which go back 3 or 4 years, others that have to do with Ximina zigging
while I zagged. I'm glad that the rpm problems are finally
being solved. Meanwhile, Red Carpet looks promising, but I'd look for a copy
linked against 4.0.3 after rease in the next couple of weeks.


Note You need to log in before you can comment on or make changes to this bug.