Bug 42515 - (Trident Cyberblade i7) Random flickering lines and static
(Trident Cyberblade i7) Random flickering lines and static
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-27 19:42 EDT by Rafael Baquero S.
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 21:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
I am enclosing the XF86Config file in case it helps. (14.42 KB, text/plain)
2001-05-27 19:44 EDT, Rafael Baquero S.
no flags Details

  None (edit)
Description Rafael Baquero S. 2001-05-27 19:42:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
After installing Red Hat Linux 7.1 on a computer with a PCChips M585LMR
motherboard I tried to configure XFree86 to use a resolution of 1024 x 768.
After using both XConfigurator and xf86config there appear small flickering
randomly placed lines similar to TV static. Also whenever you move the
mouse
the vertical lines of windows seem to "shake" a bit, i.e. instead of being
straight they appear to ondulate.

I tried installing Red Hat Linux 7.0 and observed the same behaviour.
However the system works fine with versions 6.2 and 6.1.
The monitor which is hooked to the computer is a Samsung SyncMaster 550v. I
tested the system with a Goldstar Studioworks 45i monitor and the problem
remained so I think the problem is not monitor related.

I tried installing Red Hat 6.1, saved the XF86Config file, reinstalled 7.1
and replaced the XF86Config file and the problem remained.

The video chipset is detected as a Trident Microsystems|Cyberblade/i7 and
the server suggested by Xconfigurator is the XF86_SVGA.

The monitor is detected as a SAM1035 monitor with a horizontal sync range
of 30-61 kHz. and a vertical sync range of 50-120 Hz. THIS IS WRONG. The
sync ranges for the SyncMaster 550v Monitor are 30-55 horizontal and 50-120
vertical. Should I open a separate bug report for this?

How reproducible:
Always

Steps to Reproduce:
1.Install Red Hat Linux 7.0 or 7.1
2.Configure XFree86 with Xconfigurator.
3.Do not accept the default frequencies if you use a SyncMaster 550v
monitor. Select custom and enter 30- 55 hor. and 50- 120 vertical.
4.For the resolution and color depth select 1024 x 768 24 bpp.

	

Actual Results:  When X starts you will notice small flickering lines
similar to TV static.
When you move the mouse you can notice that the vertical lines "shake".

Expected Results:  A clean display as presented by Red Hat Linux 6.2 and
6.1

Additional info:
Comment 1 Rafael Baquero S. 2001-05-27 19:44:19 EDT
Created attachment 19770 [details]
I am enclosing the XF86Config file in case it helps.
Comment 2 Mike A. Harris 2001-05-30 19:01:01 EDT
The XFree86 config file from Red Hat Linux 6.2 will not work with an
XFree86 4.x server.  If you want to use the 6.2 config, you'll need
to do:  Xconfigurator --preferxf3 --nodri

Try that config, if it doesn't work, try your config from 6.2 then.

The Trident cards are poorly supported at best in XFree86 4.x.  The 4.1.0
XFree86 release may or may not improve this.  You might want to wait a few
weeks and try the 4.1.0 release I will be making once it comes out.

Does the above suggestion fix the problem for you?
Comment 3 Rafael Baquero S. 2001-07-22 07:35:22 EDT
I tried to run Xconfigurator with the switches you mention but the result was
exactly the same. I also tried using the 6.2 files but with no results.
Comment 4 Mike A. Harris 2001-08-09 21:07:42 EDT
Please fill out a separate bug report for the monitor problem.
Always, one bug per report please.

Please attach your log file from using XFree86 4.x, and the XFree86
config file:  XF86Config-4 as well.  You can use the link below to
attach these uncompressed files.

Thanks.
Comment 5 Mike A. Harris 2001-09-18 03:44:42 EDT
Closing bug due to lack of requested information.
Please upgrade to the latest release in rawhide to see if
the problem persists.

Note You need to log in before you can comment on or make changes to this bug.