Bug 42531 - 'mount' command freezes and gives Segemntation Fault
'mount' command freezes and gives Segemntation Fault
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-27 23:34 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-06 09:02:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the complete output of the bug (6.97 KB, text/plain)
2001-05-28 11:41 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-05-27 23:34:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; U)

Description of problem:
After installing RH 7.1, I went to mount a CD, ISO9660. Have everything in /etc/fstab set correctly. It doesn't want to mount. 

At a term window, it freezes and upon rebooting to runlevel 1, the mount returns a very long list f code(s) and "segmentation fault...". I would 
have copied the text, but I couldn't get back to a prompt and/or another VC. 

I have tried another CDROM drive and even another cable. The drives both work in Windows, so its not the mainboard/cable/IDE settings. The 
original CDROM had been successfullt installing  for 2.5 years now and will install 6.2 just fine. It even craps out on the install for Mandrake 8.

Im on an ABIT PX5, Cyrix P166MX, 64MB RAM, Pioneer 24X (A24x 0104 ATAPI) CDROM, Set to "single" and have used "Master, slave, CS". 
The system is 2.5 years old. Original owner, so I know it pretty well. Dual boot, Win98/RH 7.1. I have been a Red Hat user since 1997 (4.2). If 
you need any more info, I'm at gmac63@carolina.rr.com (Charlotte, NC)

-Wes Yates

How reproducible:
Always

Steps to Reproduce:
1.boot (doesn't mater the runlevel, but 1 produces the error output
2. insert a CD
3.mount /mnt/cdrom and watch. 'mount' will either hang indefinately or will return error messages, etc.
4. give it the three-finger-salute and watch the system hang.
5. power off and hope the fs is ok.
6. rinse, lather, repeat...	

Actual Results:  As stated above (ok, the shampoo is optional)

Expected Results:  the system freezes like a nuclear winter.

Additional info:

Could be a bug, could be the op. But its annoying me.
Comment 1 Bernhard Rosenkraenzer 2001-05-28 02:57:46 EDT
My best guess is that there's a problem with the IDE chipset driver...
Arjan?
Comment 2 Arjan van de Ven 2001-05-28 05:13:11 EDT
Sounds like your cdromdrive doesn't like IDE DMA. (Windows doesn't use that,
neither did previous Red Hat Linux versions).

If you add "ide=nodma" to the lilo.conf file as append (or type it at the
prompt), DMA will be disabled for all devices; alternatively you can use
hdparm -d0 /dev/hdc   (assuming hdc is your cdrom drive) to disable DMA only for
your CDROM drive.

Could you let me know if this works, and if it does, could you attach the output
of "lspci" and "cat /proc/ide/*/model" to this bug ?
Comment 3 Need Real Name 2001-05-28 11:41:23 EDT
Created attachment 19830 [details]
the complete output of the bug
Comment 4 Need Real Name 2001-05-28 11:43:28 EDT
I have attached (sent) the output you wanted along with the output of 'dmesg',
lilo.conf, and a few more. I also captured the error from 'mount'. I tried the
addition to etc.lilo and will try the hdparm. wish me luck and hope you find an
answer... Let me know if you need more info.

-Wes Yates
Comment 5 Need Real Name 2001-05-28 11:45:03 EDT
Oooooooo.  hdparm -d0 /dev/hdc gave me a Segementation Fault....

root@clt70-042 # hdparm -d0 /dev/hdc
Segmentation fault

-Wes
Comment 6 Arjan van de Ven 2001-05-28 12:38:38 EDT
Ok, does this happen with other CD's too ?
Comment 7 Need Real Name 2001-05-28 21:12:41 EDT
Any and all CDs. I have also tried Audio CDs. That's what started this whole
thing in a way. 

I haven't tried the other CDROM with these new settings, but I can soon. Perhaps
Tomorrow.
Comment 8 Need Real Name 2001-06-03 09:20:04 EDT
UPDATE 6-2-01: I have sucessfully rebuilt my kernel and have included CDROM
support and seem to have included all modules as I had before. Now my CDRO
works! :

root@clt92-143 # lsmod
Module                  Size  Used by
nls_iso8859-1           2880   0  (autoclean)
isofs                  18304   0  (autoclean)
autofs4                 9536   1  (autoclean)
3c59x                  24896   2  (autoclean)
nls_cp437               4384   2  (autoclean)
mad16                   7776   0
ad1848                 17424   0  [mad16]
sb_lib                 34064   0  [mad16]
uart401                 6384   0  [mad16 sb_lib]
sound                  57648   0  [mad16 ad1848 sb_lib uart401]
soundcore               3984   5  [sb_lib sound]

as you see, I have not cdrom.o, therefor it must be in the kernel (2.4.4). I had
suspected that the kernel was the culprit, but I didn't know. I had tried a
completely different CDROM but no good. I also read cdrom/ide-cd in
Documentation/ line 283 (on mine) about the Pioneer:

- If you own a Pioneer DR-A24X, you _will_ get nasty error messages on boot such
as "irq timeout: status=0x50 { DriveReady SeekComplete }"

It mentions adding "serialize" as kernel args. It also says to read ide.txt for
"serialize" as to how to use that. I added "ide1=nodma ide1=serialize" to my
/etc/lilo.conf. I assume when you said to use 'ide=nodma', it would do that for
both. My cdrom is on ide1.

Anyhow, it works and you may close out this "bug". Though its not a bug, you may
find it interesting and useful since ide-cd states that the Pioneer CDROMS are
"popular".

Thanks for you help! 

BTW - one other source mentioned that kernels are "built" at the installation.
Is that true? What is the best way to tell how a kernel was "built" and
configured at install? 'lsmod' I have used to see what the current modules are,
but is there a log file or something? thanks!

-Wes Yates
gmac63@carolina.rr.com
Charlotte, NC
Comment 9 Arjan van de Ven 2001-06-05 05:24:46 EDT
We build the kernels on our big machine and put the compiled version on the
installation cd. This is because it can take a long time to build one (over half
an hour).

If you install the kernel-source rpm, you get a directory
/usr/src/linux-2.4/configs

which has all the .config files we used for the various kernels.

Note You need to log in before you can comment on or make changes to this bug.