Bug 425351 - Xorg sometimes starts a blank screen with i810
Xorg sometimes starts a blank screen with i810
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 14:40 EST by Steve Cleveland
Modified: 2012-04-17 17:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 17:08:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (64.08 KB, text/plain)
2007-12-14 14:40 EST, Steve Cleveland
no flags Details

  None (edit)
Description Steve Cleveland 2007-12-14 14:40:51 EST
Description of problem:

On a Dell SX280 with an Intel video card and the i810 driver, X will sometimes
start, but other times just creates a blank screen.  As far as I can tell, Xorg
is running and the log file makes it seem like it's running as well.  This
happens on multiple machines.

Version-Release number of selected component (if applicable):

xorg-x11-drv-i810-1.6.5-9.6.el5

How reproducible:

Sporadic

Steps to Reproduce:
1.  Boot up the machine, sometimes works, sometimes doesn't.
2.  init 3;sleep 5;init 5
3.  Again, sometimes works, sometimes doesn't
  
Actual results:

Sometimes Xorg starts and the display comes up.  Sometimes, it just produces a
blank screen.

Expected results:


Additional info:

[root@nulato ~]# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated
Graphics Controller (rev 04)

The display is a Dell 2001FP, using DVI on both ends.

Following a suggestion found on another bug report, I started Xorg without an
xorg.conf files.  I have attached the Xorg.0.log file from that attempt.
Comment 1 Steve Cleveland 2007-12-14 14:40:51 EST
Created attachment 289351 [details]
Xorg log file
Comment 2 Jos Vos 2008-01-08 16:55:22 EST
FWIW: I can't use the i810 driver anymore since RHEL 5.1 on an IBM SurePOS 565
(specific Point-of-Sale hardware, also with 82915G/GV/910GL), while RHEL 5.0
worked fine!  Starting the X server *always* (at least every time I tried)
results in a blank screen, keyboard/mouse can not be used (e.g. to switch to a
text console), but the X server stays running and the Xorg.0.log file doesn't
show any errors.  The vesa driver works ok.
Comment 3 Matěj Cepl 2008-01-21 11:32:04 EST
For official Red Hat Enterprise Linux support, please log into the Red Hat
support website at http://www.redhat.com/support and file a support ticket, or
alternatively contact Red Hat Global Support Services at 1-888-RED-HAT1 to speak
directly with a support associate and escalate an issue.

Comment 4 David Young 2008-06-13 14:37:56 EDT
I have experienced similar behavior with Fedora 9 on my Dell 700m laptop running
the 82852/855GM Integrated Graphics Device as the VGA controller.  Sporadically,
the screen will blank and hard drive starts racing when I log out or just prior
to gdm loading during startup.  The X server always starts fine during bootup,
but the black screen appears when the graphical boot screen switches to the
login screen.

I have encountered this issue up to half the time I login/logout since Fedora 8
(although it seems less frequent in Fedora 9).  I wonder if it is perhaps
related to changing screen resolution?  I saw a recent bug fix for Ubuntu 8.04:
https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel
Comment 5 Adam Jackson 2012-04-17 17:08:20 EDT
No further hardware enablement updates are planned for RHEL5's X stack.  If this issue is still present in RHEL6, please update the affected product version and reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.