Bug 42555 - stty in /etc/bashrc hangs when called from su -
Summary: stty in /etc/bashrc hangs when called from su -
Status: CLOSED DUPLICATE of bug 37615
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sh-utils   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-28 09:19 UTC by Joerg Dorchain
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-28 09:19:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joerg Dorchain 2001-05-28 09:19:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.4 i686; Nav)

Description of problem:
The stty command in /etc/bashrc hangs (strace says loops with -ERESTARTSYS)
when doing an su - <user> as root from a vt or a network login (xterm and
gnome-termnial work oddly, as well as stracing with strace -f su - <user>)
as root.

How reproducible:
Always

Steps to Reproduce:
1. Login as root on a console virtual terminal
2. su - <some other user>
3. There you are
	

Actual Results:  nothing directly visible. The process list shows a stty in
T state. Tracing this back leads to the stty in /etc/bashrc.

Expected Results:  Get a login like enviroment for the other user.


Additional info:

Both su and stty are from sh-utils-2.0-13
Kernel is 2.4.4 from kernel.org
glibc is 2.2.2-10

Comment 1 Bernhard Rosenkraenzer 2001-05-28 12:15:38 UTC

*** This bug has been marked as a duplicate of 37615 ***


Note You need to log in before you can comment on or make changes to this bug.