Bug 4256 - setconsole broken
setconsole broken
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: setconsole (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-07-29 16:28 EDT by brownb
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-31 19:22:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brownb 1999-07-29 16:28:04 EDT
When I run "setconsole ttya" I get the following error
message:

/proc/openprom/options does not exist -- cannot setup
console

For hosts without displays that are
placed in machine rooms, it is
very important that one can bypass the network and connect
directly to their serial ports in order to reboot them when
they hang.  The setconsole script is a hack, but on Red Hat
5.1 it did work.  Now it seems to be broken.
Comment 1 Jeff Johnson 1999-07-29 16:49:59 EDT
I'm assuming that you're running on a sparc :-)

Can you verify whether openpromfs is loaded by typing lsmod? Here's
what I see:

[jbj@orleans jbj]$ lsmod
Module                  Size  Used by
openpromfs             11988   4  (autoclean)
ipip                    5964   2
nfsd                  153892   8  (autoclean)

If openpromfs is not loaded, you will need to load. Try
	insmod openpromfs
Comment 2 Jeff Johnson 1999-07-31 19:22:59 EDT
If you are running on an i386 platform, then setconsole is not
for you. You need to use lilo boot options to set the serial
parameters. Setconsole works only on sparcs.

Note You need to log in before you can comment on or make changes to this bug.