Bug 42570 - No Socket-connections possible (NET-Module) / Perl 5.6.1 not compileable (socks5p.h is missing)
No Socket-connections possible (NET-Module) / Perl 5.6.1 not compileable (soc...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-28 09:17 EDT by Alex Pircher
Modified: 2010-05-13 15:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-06 16:24:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Pircher 2001-05-28 09:17:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [de] (WinNT; U)

Description of problem:
1. No Socket-connections possible (NET-Module): See steps to reproduce
Fix would be to upgrade to Perl 5.6.1, but ...

... 2. Perl 5.6.1 is not compileable because socks5p.h is missing
In socks5-devel-1.0r11-2.i386.rpm there is socks.h but socks.h needs also socks5p.h and this one isn't here.

How reproducible:
Always

Steps to Reproduce:
1. perl -e 'use Net::FTP; $ftp = Net::FTP->new("localhost");print $@;'
	

Actual Results:  It prints out "Timeout"

Expected Results:  It should print out nothing.

Additional info:

Fix:

1. Install socks5-v1.0r11 (socks5-1.0r11-1.src.rpm)
(socks5p.h is missing in socks5-devel-1.0r11-2.i386.rpm!)
Copy include-files needed by socks.h:
cp include/* /usr/local/include/
Remove dynamic Socks-Library, else Perl gives an error:
rm /usr/local/lib/libsocks5_sh.so

2. Remove Perl 5.6.0
rm -rf /usr/local/lib/perl5/

3. Install Perl 5.6.1

4. Install libnet-1.0703
"make test" should successfully open an FTP-Connection

5. Install remaining Perl-Modules
Comment 1 Alex Pircher 2001-06-26 04:19:15 EDT
The same unter RH 7.1 ... the problem is that there are no socks-libraries on the system.
So the actual question is which package should be installed to get the socks-libraries? dante/socks5-package

The rpm-install, copy and remove of a few files couldn't be the straight way!
Comment 2 Chip Turner 2001-12-19 03:30:29 EST
perl 5.6.1 is now available in rawhide
Comment 3 Alex Pircher 2001-12-19 03:52:25 EST
For all who don't know what Rawhide is: http://people.redhat.com/tcallawa/faq.html#rawhide

Note You need to log in before you can comment on or make changes to this bug.