Bug 425701 - openoffice.org-langpack-sr locale should now be sr_RS instead of sr_CS
openoffice.org-langpack-sr locale should now be sr_RS instead of sr_CS
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 18:58 EST by Filip Miletic
Modified: 2008-01-22 10:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.11.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:42:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 71789 None None None Never
OpenOffice.org 83410 None None None Never

  None (edit)
Description Filip Miletic 2007-12-14 18:58:42 EST
Description of problem:
Fedora 7 began using sr_RS throughout as the locale for Serbian language.  This
is also true for Fedora 8.

The language pack for Serbian OpenOffice still uses sr_CS, which is the old
locale.  As a consequence, a regular user that would like to use Serbian UI can
not get the OpenOffice UI in Serbian.

Version-Release number of selected component (if applicable):
openoffice.org-langpack-sr-2.3.0-6.7.fc8


How reproducible:


Steps to Reproduce:
1. start LC_ALL=sr_RS.UTF-8 oowriter
2. verify that oowriter starts up with the UI in English
  
Actual results:
oowriter starts up with the UI in English

Expected results:
oowriter should start up with the UI in Serbian

Additional info:
Comment 1 Caolan McNamara 2007-12-16 07:40:09 EST
backported workspace.locales24.patch to resolve this, will be in the next update
and committed to devel
Comment 2 Fedora Update System 2008-01-06 20:19:05 EST
openoffice.org-2.3.0-6.10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 3 Filip Miletic 2008-01-10 12:20:56 EST
I installed the updates, but I still see sr_CS being used instead of sr_RS...
Comment 4 Caolan McNamara 2008-01-10 12:42:17 EST
Do you mean the name of the langpack ? That won't be changed in F8, that ship
has sailed. Though it is renamed in rawhide for F-9.
Comment 5 Filip Miletic 2008-01-10 12:48:40 EST
I mean that if I repeat the 'Steps to reproduce' from the first message in this
bug, I still get an UI in English, instead in Serbian.  Which is precisely the
reason I filed this bug in the first place.

f
Comment 6 Caolan McNamara 2008-01-10 13:05:47 EST
well then I guess it didn't work
Comment 7 Caolan McNamara 2008-01-11 04:29:53 EST
Ack, I see the problem. What a mess. Hopefully I can figure out the necessary
extra fix for this.
Comment 8 Filip Miletic 2008-01-11 04:42:15 EST
This also needs to redirect the 'sr' locale to 'sr_RS'.  Using 'LC_ALL=sr' on my
Fedora 8 box says 'Locale not supported by X server'.
Comment 9 Caolan McNamara 2008-01-14 06:23:43 EST
oky doky, openoffice.org-2.3.0-6.11.fc8 works for me with locale sr_RS.UTF-8.
That'll be pushed to testing soon
Comment 10 Fedora Update System 2008-01-15 18:06:31 EST
openoffice.org-2.3.0-6.11.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 11 Filip Miletic 2008-01-16 02:24:14 EST
I tried 'oowriter' and 'ooimpress' with LC_ALL=sr_RS.UTF-8 and the string labels
seem to be displayed correctly in Serbian. 

Comment 12 A S Alam 2008-01-22 05:43:14 EST
I have tested with following pacakge:
openoffice.org-core-2.4.0-3.2.fc9
(with given instructions, it was running in sr locale)
Comment 13 Fedora Update System 2008-01-22 10:41:53 EST
openoffice.org-2.3.0-6.11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.