Bug 42574 - rpm-4.0.2 core dumps when rpm -qa or --rebuilddb
Summary: rpm-4.0.2 core dumps when rpm -qa or --rebuilddb
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-28 14:48 UTC by Werner Lueckel
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-30 19:28:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Werner Lueckel 2001-05-28 14:48:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
I've upgraded from rpm-3.0.4 to rpm-4.0.2 by loading all required packages 
(popt, db3, rpm, phyton); when trying to rebuild the databese (--
rebuilddb) rpm starts, but after a while it coredumps with Segmentation 
fault
same happens, when trying "rpm -qa"; rpm starts listing the installed 
packages, but then coredumps (always with the same package: ghostscript-
hpijs; but, this package CAN be displayed properly with a single query 
(rpm -qi ghostscript-hpijs).

How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuilddb     --> core dump
2. rpm -qa             --> core dump
3. 
	

Additional info:

however, the "coredump" seems to be focussed on "some" installed packages, 
which are:
   ghostscript, ghostscript-hpijs, ghostscript-fonts
I've downloaded them from "hp linux inkjet driver project",
http://hpinkjet.sourceforge.net/binaryinstall.php

I can't remove or update them, and unfortunately I can't upgrade my rpm 
database; 

some examples:

[root@greypc rpm402]#  rpm --rebuilddb
Segmentation fault (core dumped)
[root@greypc rpm402]# file core
core: ELF 32-bit LSB core file of 'rpmdb' (signal 11), Intel 80386, 
version 1


root@greypc rpm402]# rpm -qa
ElectricFence-2.1-3
setup-2.1.8-1
filesystem-1.3.5-1
...gftp-2.0.6a-3
ghostscript-5.50-1
Segmentation fault (core dumped)
[root@greypc rpm402]# file core
core: ELF 32-bit LSB core file of 'rpmq' (signal 11), Intel 80386, version 
1
[root@greypc rpm402]#

[root@greypc /root]# rpm -ev ghostscript-fonts
Segmentation fault (core dumped)
[root@greypc /root]# file core
core: ELF 32-bit LSB core file of 'rpm' (signal 11), Intel 80386, version 1

Comment 1 Jeff Johnson 2001-05-29 20:11:26 UTC
The two hpijs packages install fine for me, so that's not the problem.

Please attach a pointer to a tar ball of your database
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm
Thanks.

Comment 2 Jeff Johnson 2001-05-30 19:28:26 UTC
I have a fix for the problem, will get new packages on ftp.rpm.org
in the next day or so ...

Comment 3 Jeff Johnson 2001-05-30 22:51:41 UTC
The changes necessary are checked into CVS, gonna take a couple days to get
6.x packages built. Meanwhile, you can build from CVS by doing
	cvs -d :pserver:anonymous@cvs.rpm.org:/cvs/devel login
	(no password, just carriage return)
	cvs -d :pserver:anonymous@cvs.rpm.org:/cvs/devel get rpm
	cd rpm
	cvs up -r rpm-4_0
	./autogen.sh
	make
	make install
and then do
	rpm --rebuilddb
to convert from db1 (and skip your problem) to db3 ...



Note You need to log in before you can comment on or make changes to this bug.