Bug 425767 - 2.6.23.* kernel causes hang during starting udev
2.6.23.* kernel causes hang during starting udev
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-15 04:05 EST by TonyCrouch
Modified: 2008-06-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:56:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description TonyCrouch 2007-12-15 04:05:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc7 Firefox/2.0.0.10

Description of problem:
On installing any kernel with the architecture 2.6.23.* my compaq nx9010 notebook refuses to boot. In particular, it "hangs" at the "Starting udev" stage of the boot process.

Version-Release number of selected component (if applicable):
kernel-2.6.23.8-34.fc7

How reproducible:
Always


Steps to Reproduce:
1. Ensure 2.6.23.* kernel is installed.
2. Boot laptop
3. Laptop will "hang" while "starting udev" is displayed.

Actual Results:
Notebook refuses to boot.

Expected Results:
Notebook should boot successfully.

Additional info:
This problem occurs on all kernels beginning with 2.6.23.*

Here is the output of /sbin/lspci:
[tony@localhost ~]$ /sbin/lspci
00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (rev 02)
00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
00:07.0 ISA bridge: ALi Corporation M1533/M1535 PCI to ISA Bridge [Aladdin IV/V/V+]
00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
00:09.0 Network controller: Broadcom Corporation BCM4303 802.11b Wireless LAN Controller (rev 02)
00:0a.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:0b.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:0b.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:0b.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
00:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
00:11.0 Bridge: ALi Corporation M7101 Power Management Controller [PMU]
00:12.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller
01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M

Here is the output of my /sbin/lsmod:
[tony@localhost ~]$ /sbin/lsmod
Module                  Size  Used by
vfat                   16193  1 
fat                    53341  1 vfat
usb_storage            77313  1 
autofs4                24773  2 
hidp                   26689  2 
rfcomm                 44377  0 
l2cap                  30401  10 hidp,rfcomm
bluetooth              57893  5 hidp,rfcomm,l2cap
sunrpc                161981  1 
nf_conntrack_netbios_ns     7104  0 
nf_conntrack_ipv4      15049  2 
ipt_REJECT              8641  2 
iptable_filter          7105  1 
ip_tables              16517  1 iptable_filter
nf_conntrack_ipv6      23505  2 
xt_state                6593  4 
nf_conntrack           63049  4 nf_conntrack_netbios_ns,nf_conntrack_ipv4,nf_conntrack_ipv6,xt_state
nfnetlink               9945  3 nf_conntrack_ipv4,nf_conntrack_ipv6,nf_conntrack
xt_tcpudp               7233  8 
ip6t_REJECT             9537  2 
ip6table_filter         6849  1 
ip6_tables             17669  1 ip6table_filter
x_tables               18629  6 ipt_REJECT,ip_tables,xt_state,xt_tcpudp,ip6t_REJECT,ip6_tables
dm_mirror              25153  0 
dm_multipath           21961  0 
dm_mod                 57089  2 dm_mirror,dm_multipath
video                  20937  0 
sbs                    22729  0 
button                 12113  0 
dock                   13921  0 
battery                14149  0 
ac                      9285  0 
radeon                116961  3 
drm                    80085  4 radeon
ipv6                  277957  22 nf_conntrack_ipv6,ip6t_REJECT
snd_ali5451            25933  2 
snd_ac97_codec         96613  1 snd_ali5451
ac97_bus                6465  1 snd_ac97_codec
snd_seq_dummy           7877  0 
snd_seq_oss            33473  0 
snd_seq_midi_event     11073  1 snd_seq_oss
snd_seq                50609  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         11981  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            43457  0 
snd_mixer_oss          19521  2 snd_pcm_oss
snd_pcm                74949  3 snd_ali5451,snd_ac97_codec,snd_pcm_oss
i2c_ali1535            10821  0 
ssb                    35269  0 
parport_pc             30821  0 
i2c_ali15x3            11589  0 
firewire_ohci          20801  0 
snd_timer              24901  2 snd_seq,snd_pcm
floppy                 58661  0 
parport                38281  1 parport_pc
snd                    53317  11 snd_ali5451,snd_ac97_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
firewire_core          43137  1 firewire_ohci
i2c_core               27841  2 i2c_ali1535,i2c_ali15x3
soundcore              11681  2 snd
bcm43xx               420705  0 
ieee80211softmac       35393  1 bcm43xx
natsemi                31521  0 
snd_page_alloc         14281  1 snd_pcm
crc_itu_t               6337  1 firewire_core
ieee80211              35593  2 bcm43xx,ieee80211softmac
ieee80211_crypt        10049  1 ieee80211
sr_mod                 20837  0 
sg                     37469  0 
cdrom                  37089  1 sr_mod
joydev                 13825  0 
ata_generic            11589  0 
pata_ali               14529  3 
libata                118321  2 ata_generic,pata_ali
sd_mod                 31297  6 
scsi_mod              140749  5 usb_storage,sr_mod,sg,libata,sd_mod
ext3                  125641  2 
jbd                    59881  1 ext3
mbcache                12485  1 ext3
ehci_hcd               35405  0 
ohci_hcd               23877  0 
uhci_hcd               27089  0 

If there is any further information you require, please do not hesitate to let me know.
Comment 1 Chuck Ebbert 2007-12-18 17:18:16 EST
Try the workarounds from https://fedoraproject.org/wiki/KernelCommonProblems

Also, this bug may be fixed in kernel 2.6.23.10-51.fc7 which will go into
testing soon.
Comment 2 TonyCrouch 2007-12-29 01:10:48 EST
Hi Chuck,
Thanks for the link and the information regarding the new kernel.

I am currently on holidays and won't get an opportunity to try the problems
listed in the link until late January.

I will update this bug at the earliest opportunity ... stay tuned.

Thanks again.
TC
Comment 3 TonyCrouch 2008-01-08 03:27:21 EST
Hi Chuck, 
Am just wanting to let you know I have tried most of the things on the "common
problems" section, but all seem to be to no avail.

I have since tried to update my kernel to: kernel-2.6.23.12-52.fc7, but this
does not work. So, I am still currently using kernel-2.6.22.9-91.fc7.

If there is anything I can do to help you with this bug just let me know.

Cheers, 
TC
Comment 4 TonyCrouch 2008-01-16 05:15:48 EST
Just thought I would add that I have also tried the workarounds suggested at the
following website:

http://forums.fedoraforum.org/archive/index.php/t-171295.html

Neither of these suggestions, (1 - adding the acpi commands to the boot options
& 2 - disabling the b43 modules in modprobe) worked successfully.

When trying option (2) the system still hung without warning at the "starting
udev" prompt.

When trying option (1) & (2) the still hung at this point but also produced the
following error message:

Disabling IRQ#10

Just thought I should make mention in case it helps.

Thank you for your assistance.

Cheers, 
TC
Comment 5 TonyCrouch 2008-04-14 20:51:25 EDT
Hi, 
Am just wanting to let you know I have finally got the chance to update my
kernel to:

kernel-2.6.23.15-80.fc7

But unfortuantely, my system still hangs at the "Starting udev" phase when booting.

I am a little bit hesitant with regards to doing a fresh-install of F8 as I
believe (and please correct me if I am wrong) the default kernel is of
architecture 2.6.23.*, so going by my machine's past habits it will load and
then refuse to boot leaving me with an unworkable system and having to reload F7
from scratch ... definitely not a fun prospect.

If there's anything I can do to help this case in its progress, just ask.

Thanks again.

All the best.

Cheers, 
Tony Crouch
Comment 6 Bug Zapper 2008-05-14 11:10:08 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Bug Zapper 2008-06-16 22:55:57 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.