Bug 425771 - Possibly-broken AP causes wireless adapter errors
Possibly-broken AP causes wireless adapter errors
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-15 05:19 EST by Kyrre Ness Sjøbæk
Modified: 2008-01-16 12:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 12:06:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snippet from dmesg (2.06 KB, text/plain)
2007-12-15 05:19 EST, Kyrre Ness Sjøbæk
no flags Details
messages log (/var/log/messages) (352.83 KB, text/plain)
2007-12-18 13:52 EST, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2007-12-15 05:19:52 EST
Description of problem:
If i switch on my laptop in the area covered by an (probably somewhat faulty)
SMC AP, it detects that AP, and the network card freezes. I have attached a log
of dmesg output after network card activates and tries to connect.

When this has happened, the card no longer responds to commands, and everything
that tries to interact with it times out. This makes NetworkManager ask for
password again and again, and no further networks will be found by a scan.

After this has happened, only way to use card is to remove power from the AP,
and unload/load iwl3945.

Note that this happened with the ipw driver as well.

Version-Release number of selected component (if applicable):
iwl3945-firmware-2.14.1.5-1

How reproducible:
Every time lately

Steps to Reproduce:
1. Switch on laptop/bring it out of suspend when in range of the AP
2. NetworkManager tries to connect (im not shure even this is neccessary)
3. Boom.
  
Actual results:
Card crashes

Expected results:
Card function well

Additional info:
The AP in question:
http://www.komplett.no/k/ki.asp?sku=313252

I have been able to connect when more or less sitting on top of the AP, so this
may have something to do with what happens when the signal strength is poor.

Also, my father (using an IBM thinkpad with WinXP, unknown card) are able to
connect, but it is "very slow".
Comment 1 Kyrre Ness Sjøbæk 2007-12-15 05:19:52 EST
Created attachment 289683 [details]
Snippet from dmesg
Comment 2 Matthias Saou 2007-12-17 16:02:20 EST
Reassigning to kernel, since this isn't firmware dependent.
Please detail which kernel version you're using. You could also try with Fedora
8 to see if things are any better.
Comment 3 John W. Linville 2007-12-18 11:27:21 EST
Please try a recent F7 kernel e.g.:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=28164

Does this work any better for your iwl3945?
Comment 4 Kyrre Ness Sjøbæk 2007-12-18 13:50:22 EST
One certain bug in that kernel: During boot (quite early, before the "Welcome to
Fedora Core" (or something like that) message) i get 7 messages that states
"pnpacpi: exeeded the max number of mem resources: 12"...

However, this now seems more and more unrelated to the AP - the error messages
occured when the AP wasn't even powered. However, i was this time able to
connect to an unencrypted AP (neighbours -- blame NetworkManager if it was
techically illegal). And the "stuttering" of the mouse that has previously
occured together with this, did not happen. However, after a while, I wasn't
able to scan (tried to initiate a scan manually with iwlist, as NetworkManager
didn't bring anything up).

Hmm.. Could this be a faulty card? The strange thing is, it worked like a charm
when I was at the university, but not at home. Possible that it something else
causing interference here? Strange it is...
Comment 5 Kyrre Ness Sjøbæk 2007-12-18 13:52:14 EST
Created attachment 289914 [details]
messages log (/var/log/messages)
Comment 6 Christopher Brown 2008-01-15 23:44:11 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 7 Kyrre Ness Sjøbæk 2008-01-16 11:51:37 EST
I don't think there has been any kernel updates since the one posted in comment
#3. However, I have reset the router, so it now works merrily, as I did not get
any reply from here and the hardware was needed by other family members. That
means I cannot for now help you anymore.

But this probably excludes "faulty card" as an explanation, as everything worked
nicely after resetting the router (nothing changed on the PC).

Close this bug for now, and i'll reopen if the problem reappears.
Comment 8 Christopher Brown 2008-01-16 12:06:02 EST
Hello Kyrre,

Thanks for the update. Will close as requested. Thanks also for taking the time
to file the original bug.

Note You need to log in before you can comment on or make changes to this bug.