Bug 425772 - Networkmanager should have "rescan"-button
Networkmanager should have "rescan"-button
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-15 05:23 EST by Kyrre Ness Sjøbæk
Modified: 2008-04-23 13:24 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.6.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 09:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2007-12-15 05:23:11 EST
Description of problem:
There should be a button in the network list to manually trigger a rescan of
aviable AP's.

Version-Release number of selected component (if applicable):
NetworkManager-gnome-0.6.5-7.fc7
NetworkManager-0.6.5-7.fc7

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 info 2008-02-03 07:08:37 EST
I second this request and like to add some details. It never picks up a new 
network unless I restart the NetworkManager daemon manually from commandline. 

The big problem seems to be when the wifi card is enabled AFTER NetworkManager 
is started. This is the normal case for a laptop, as nm is started at bootup, 
but one enables the card only much later when needed.

This is with NetworkManager-0.7.0-0.6.7.svn3204.fc8.
Comment 2 Dan Williams 2008-04-22 14:46:01 EDT
The scan algorithm in 0.6.6 available from F7 updates has been tweaked to be
more responsive.  Please test and see if that works better for you.  But it's
expected that an AP that you've just turned on will take some time (30s or so)
to show up in the list.
Comment 3 Kyrre Ness Sjøbæk 2008-04-22 15:37:34 EDT
If it is the same as with 0.6.6-1, its much better, but not perfect. It would
still be nice with a manual "rescan" button - very usefull if you just picked up
the laptop and went to another place in the building (where somebody is waiting
for you and your internet connection, and maybe even the network coverage is
somewhat weak...).

So: Better, but I still want a manual button somehow.
Comment 4 Dan Williams 2008-04-23 09:45:34 EDT
Ok, you may want it, but there's not ever going to be one... :(
Comment 5 Kyrre Ness Sjøbæk 2008-04-23 13:24:08 EDT
Why? Is it a political descission, like gnome opening every folder in a new
window (something that is really, really annoying - I think i have shown about
30-50 people now how to change it, and they have are all been very gratefull for
getting rid of the stupid "open folder, close the parent, open next folder,
close the parent" interface - which is extremely bothering when you have deep
trees...)?

Where can I find more info on this desscision?

Note You need to log in before you can comment on or make changes to this bug.