Bug 425777 - Laptop hangs when wireless association lost
Summary: Laptop hangs when wireless association lost
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-15 12:46 UTC by Adam Huffman
Modified: 2008-01-08 23:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-08 23:42:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Huffman 2007-12-15 12:46:06 UTC
Description of problem:
Over the past few weeks I have found that when association is lost to my home
wireless network (often caused by our answering machine interfering with the
router), the laptop is freezing and I have to do a hard reboot.

Version-Release number of selected component (if applicable):
kernel-2.6.23.8-63.fc8

How reproducible:
Every time

Steps to Reproduce:
1.
2.
3.
  
Actual results

Expected results:


Additional info:
Here's the laptop:

http://www.smolts.org/show?UUID=797a5df5-36c6-487e-81e2-11ac0c0011fb

Comment 1 John W. Linville 2007-12-17 15:50:14 UTC
Can you capture the output of Alt-Sysrq-T?

Comment 2 Adam Huffman 2007-12-17 20:40:44 UTC
I'll try, though it's usually in X when it happens and it doesn't react to the
keyboard at all.

Comment 3 John W. Linville 2007-12-19 14:21:44 UTC
Someone has suggested that you might be using the ipw3945 driver rather than 
the iwl3945 driver ("ipw" vs "iwl").  I have no idea how they determined this 
from this bug report, but I thought I would ask...is that so?

Comment 4 Adam Huffman 2007-12-19 23:19:15 UTC
It isn't, no.

Comment 5 John W. Linville 2008-01-04 22:30:10 UTC
Could you add "options iwl3945 debug=0x43fff" to /etc/modprobe.conf, reboot, 
recreate the problem, then attach the contents of /var/log/messages to this 
bug?

Thanks!

Comment 6 Adam Huffman 2008-01-08 23:40:58 UTC
I've added that setting but haven't seen the problem for a few weeks now, so I'm
closing the bug.  I'll re-open if it recurs.


Note You need to log in before you can comment on or make changes to this bug.