Bug 425781 - Please rebuild digikam against current libpng
Please rebuild digikam against current libpng
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: digikam (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcin Garski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-15 11:15 EST by Roland Wolters
Modified: 2008-05-05 08:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-05 08:19:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 144268 None None None Never

  None (edit)
Description Roland Wolters 2007-12-15 11:15:33 EST
Description of problem:
According to the rpm header digikam was rebuild on
Build Date: Mi 19 Sep 2007 17:48:55 CEST
Howerver, a newer libpng exists:
Build Date: Do 18 Okt 2007 18:50:21 CEST

There is a bug in Fedora's current digikam when handling specific png data 
which is related to libpng. See the linked KDE bug for more information.

Version-Release number of selected component (if applicable):
Version     : 0.9.2
Release     : 5.fc8 

How reproducible:
Go to the KDE bug report and try to open the linked problematic png images.

Steps to Reproduce:
1. Go to the KDE bug entry.
2. Download the problematic png image.
3. Try to open it with showfoto.
  
Actual results:
Showfoto doesn't open the image due to an error in libpng (see terminal 
output).

Expected results:
It should just work.

Additional info:
This can be probably solved by rebuilding digikam against libpng.
Comment 1 Fedora Update System 2007-12-20 14:51:58 EST
digikam-0.9.2-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update digikam'
Comment 2 Marcin Garski 2007-12-20 17:20:18 EST
Roland could you test if 6.fc8 release resolves your problem?
Comment 3 Roland Wolters 2007-12-21 03:08:29 EST
Unfortunately, that doesn't solve the problem - I wonder why.
Do you see problems when you try to open the image linked in the KDE bug 
report with showfoto?
Comment 4 Marcin Garski 2007-12-29 16:14:52 EST
I have updated digikam to 0.9.3. Soon it will be pushed to updates, please
update your package and check if problem still exist.
Comment 5 Roland Wolters 2008-01-03 11:40:10 EST
Looks like the problem still exists for me, sadly. Is the blog valid on your 
machine as well?
Comment 6 Antonio Bulgheroni 2008-01-19 15:44:49 EST
I'm also unable to start both digikam and showfoto. For both of them I don't
have any debug output but they crash as soon as launched from the command line. 

I'm currently using digikam 0.9.3-1
Comment 7 Rex Dieter 2008-05-05 08:19:14 EDT
Looks like we're stumped here, let's continue tracking this upstream.

Note You need to log in before you can comment on or make changes to this bug.