Bug 425786 - Add support to E7221 Graphics adapter (0x258a) into kernel
Summary: Add support to E7221 Graphics adapter (0x258a) into kernel
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 425788
TreeView+ depends on / blocked
 
Reported: 2007-12-15 17:52 UTC by Carlos Martín
Modified: 2008-04-02 02:09 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 18:14:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel spec updated with patch (101.52 KB, text/x-rpm-spec)
2007-12-15 17:56 UTC, Carlos Martín
no flags Details
DRM support (908 bytes, patch)
2007-12-15 17:57 UTC, Carlos Martín
no flags Details | Diff
IntelFB support (not tested) (4.82 KB, text/x-patch)
2007-12-15 17:58 UTC, Carlos Martín
no flags Details
agpgart support (3.03 KB, patch)
2007-12-15 17:59 UTC, Carlos Martín
no flags Details | Diff

Description Carlos Martín 2007-12-15 17:52:25 UTC
Description of problem:
E7221 graphics controller is a refurbised version of i915 graphics controller
bat with a different IG (0x258A) and diferrent HB (0x2588) Support it it's
trivial. There's no AGPGART support to this chipset currently so DRM doesn't
work and intel driver fails with X.

Version-Release number of selected component (if applicable):
All 


Additional info:
There are other packages involved in full E7221 support.

Comment 1 Carlos Martín 2007-12-15 17:56:28 UTC
Created attachment 289692 [details]
Kernel spec updated with patch

Comment 2 Carlos Martín 2007-12-15 17:57:59 UTC
Created attachment 289693 [details]
DRM support

Comment 3 Carlos Martín 2007-12-15 17:58:28 UTC
Created attachment 289694 [details]
IntelFB support (not tested)

Comment 4 Carlos Martín 2007-12-15 17:59:01 UTC
Created attachment 289695 [details]
agpgart support

Comment 5 Carlos Martín 2007-12-15 18:00:43 UTC
DRM and AGPGART patches works for me on a supermicro P8SCT motherboard, and X
configured with intel driver. i810 Drivers also works but not so well.

Comment 6 Adam Jackson 2008-02-21 18:14:45 UTC
This is included in current kernel builds.  Closing.

Comment 7 Don Domingo 2008-04-02 02:09:58 UTC
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don


Note You need to log in before you can comment on or make changes to this bug.