Bug 425787 - System fails to find /dev/root during first boot after install
System fails to find /dev/root during first boot after install
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-15 12:58 EST by David Rector
Modified: 2009-01-09 00:30 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 00:30:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Rector 2007-12-15 12:58:51 EST
Description of problem:
Hello Everyone,

I am helping a friend to install Fedora 8 on his laptop.

It is a HP pavilion dv9000 with Vista. After partitioning the disk with
qtparted, we installed FC8 x86_64 with no glitches.

On the first boot, we never get any joy because the system always gives us
/dev/root not found and stops with a kernel panic.

I have searched bugzilla and Fedora Forum for a solution, but I think this is
still a serious bug. Many people had this problem when FreeBSD was installed on
their drive, or had a RAID drive. But in this case, there are only four
partitions, two for Vista, one for linux root and one for linux swap.

I have tried turning off apic and apm in grub, but no joy.
I have tried booting the rescue disk and reinstalling GRUB, still no joy.
I have tried booting the rescue disk, doing a yum update, and rerunning mkinitrd
as suggested in other bug reports, still doesn't work.
Changing root=/dev/sda3 from LABEL=/ did not work either.

I suspect there is something in the sata hard drive driver, however, I am
curious why the system boots fine using the install disk?

Thanks in advance.


Version-Release number of selected component (if applicable):
Fedora 8

How reproducible:
Every Time

Steps to Reproduce:
1. Install Fedora 8 from install 8
2. reboot
3. system hangs after nash with /dev/root not found among other things.
  For example, it also claims it can't resume because it could not find the swap
disk, but I assume this is a related problem to a bigger issue because when I
add noresume to the boot parameters, this message no longer appears, but
/dev/root is still not found
  
Actual results:


Expected results:


Additional info:
Comment 1 Chuck Ebbert 2007-12-18 17:03:04 EST
Please remove the options

  rhgb quiet

from the kernel command line and replace them with

  vga=1

Then see if there are any more error messages.
Comment 2 Bug Zapper 2008-11-26 04:00:35 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-01-09 00:30:52 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.