Bug 425805 - Resolving tex-preview and texlive file conflicts
Resolving tex-preview and texlive file conflicts
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive-texmf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-15 20:43 EST by Jonathan Underwood
Modified: 2013-07-02 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2007-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 02:06:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2007-12-15 20:43:51 EST
Description of problem:
Texlive includes components that were previously provided as add-ons for tetex. 

For example, emacs-auctex created a tetex-preview subpackage as an add-on for
tetex to provide preview.sty and friends, which were absent from tetex. However,
texlive includes preview.sty and so I have stopped the emacs-auctex package
creating tetex-preview. However, currently this will break the upgrade path,
since a user who has tetex-preview installed will find no upgrade package in
F-9, and the installed tetex-preview will (should) conflict with texlive-texmf.
Presumably the way to handle this is to add Obsoletes: tetex-preview to
texlive-texmf. 

However, this can't be the only situation of this type, so I'm opening a bug
report for discussion as to the best way to deal with these.
Comment 1 Jonathan Underwood 2007-12-17 16:11:49 EST
In light of your recent mailing to fedora-devel, perhaaps it is preferable for
me to continue to create a tex-preview subpackage, and to remove it from TeX
live - the AucTeX package is upstream for preview.sty.
Comment 2 Jindrich Novy 2007-12-18 02:42:57 EST
Yes, let me know as soon as you package it separately and package is reviewed
and I will remove it from TeXLive.
Comment 3 Jonathan Underwood 2007-12-23 14:37:05 EST
Have re-enabled building of the separate preview package from AucTeX in
emacs-auctex-11.84-5.fc9 which produces tex-preview-11.84-5.fc9.noarch.rpm as a
subpackage. The details of the subpackage can be found at
http://koji.fedoraproject.org/koji/rpminfo?rpmID=332631. The files in the
tex-preview package are listed below - these will need to be removed from
texlive-texmf.


/usr/share/texmf/doc/latex/styles
/usr/share/texmf/doc/latex/styles/preview.dvi
/usr/share/texmf/tex/latex/preview
/usr/share/texmf/tex/latex/preview/prauctex.cfg
/usr/share/texmf/tex/latex/preview/prauctex.def
/usr/share/texmf/tex/latex/preview/prcounters.def
/usr/share/texmf/tex/latex/preview/preview.sty
/usr/share/texmf/tex/latex/preview/prfootnotes.def
/usr/share/texmf/tex/latex/preview/prlyx.def
/usr/share/texmf/tex/latex/preview/prshowbox.def
/usr/share/texmf/tex/latex/preview/prshowlabels.def
/usr/share/texmf/tex/latex/preview/prtightpage.def
/usr/share/texmf/tex/latex/preview/prtracingall.def
Comment 4 Jindrich Novy 2007-12-27 03:10:24 EST
Should I also remove files in /usr/share/texmf/doc/latex/preview/ ? It seems we
want to remove them as well.
Comment 5 Jonathan Underwood 2007-12-27 07:39:42 EST
(In reply to comment #4)
> Should I also remove files in /usr/share/texmf/doc/latex/preview/ ? It seems we
> want to remove them as well.

Yes indeed.
Comment 6 Jindrich Novy 2008-01-04 02:05:05 EST
I removed preview from rawhide texlive, feel free to add it separately and let
me know as soon as you add it so I can make texlive-texmf require it. Thanks!
Comment 7 Jonathan Underwood 2008-01-04 06:49:50 EST
Thanks Jindrich. tex-preview is already be available in rawhide, so you can go
ahead and Require it.

Note You need to log in before you can comment on or make changes to this bug.