Bug 425825 - moodle: broken deps
moodle: broken deps
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: moodle (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: EPEL5-BrokenDeps
  Show dependency treegraph
 
Reported: 2007-12-16 05:29 EST by Thorsten Leemhuis
Modified: 2008-01-22 08:27 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 08:27:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-12-16 05:29:25 EST
Description of problem:
package: moodle - 1.8.2-1.el5.noarch from epel5-testing
  unresolved deps: 
     perl(Text::Aspell)
     mimetex

Additional info:
I'd like to see the above problems solved.

Jerry, would you be willing to take care of perl(Text::Aspell) in EPEL5?

Jorge, would you be willing to take care of mimetex in EPEL5?
Comment 1 Jerry James 2007-12-16 23:24:12 EST
I've never contributed to EPEL before, so I don't really know what's involved. 
As long as I can do mock builds for EPEL on my Fedora 8 machine, it should be
fine.  I'll give it a try, but possibly not until I start my Christmas holiday
in a week.  I'll try to do it sooner, but I'm not going to promise.

The Summary line on this bug needs a typo fix: moddle -> moodle.
Comment 2 Thorsten Leemhuis 2007-12-17 01:52:19 EST
(In reply to comment #1)
> I've never contributed to EPEL before, so I don't really know what's involved. 

See
http://fedoraproject.org/wiki/EPEL/

> As long as I can do mock builds for EPEL on my Fedora 8 machine, it should be
> fine.

Should work.

>  I'll give it a try, but possibly not until I start my Christmas holiday
> in a week.  I'll try to do it sooner, but I'm not going to promise.

thx

> The Summary line on this bug needs a typo fix: moddle -> moodle.

you (afaik) could have done that yourself ;-)
Comment 3 Jon Ciesla 2007-12-17 08:24:02 EST
May I ask how a mock build of a PHP app would be helpful?  PHP app requires
checking is a painstaking process involving the manual checking of the spec
against the repo, a process that can take some time and has for me on other
packages, and is a process that I have obviously failed to do properly for
Moodle. :)
Comment 4 Thorsten Leemhuis 2007-12-17 08:37:32 EST
(In reply to comment #3)
> May I ask how a mock build of a PHP app would be helpful?

Please use the mailing list
https://www.redhat.com/mailman/listinfo/epel-devel-list

I can't answer this, sorry.
Comment 5 Jon Ciesla 2007-12-17 08:46:21 EST
Sorry, forgot to include the <rhetorical> tag. :)
Comment 6 Thorsten Leemhuis 2007-12-17 08:58:44 EST
(In reply to comment #5)
> Sorry, forgot to include the <rhetorical> tag. :)

And I maybe should have looked closer/read the comment properly ;)
Comment 7 Jon Ciesla 2007-12-21 10:55:19 EST
Jerry, all you really would need to do is request a branch for EL-5, then build.
 Honestly, EPEL contribtion is very easy. I've yet to catch any bug from EPEL
until this one, simply because most get found and fixed in Fedora, or usually
rawhide.  You don't even have to worry about updates, with the exception of
security.

If you'd rather not, I'll be happy to co-maintain for EPEL purposes, just
request the branch and let me take ownership.  That goes for Jorge as well.
Comment 8 Jerry James 2007-12-21 12:56:15 EST
I have verified that perl-Text-Aspell builds in mock, and have requested a CVS
branch for it.  Stand by for a build.
Comment 9 Jerry James 2007-12-22 00:49:26 EST
Okay, it's built.  Have fun!
Comment 10 Thorsten Leemhuis 2007-12-22 06:23:07 EST
(In reply to comment #9)
> Okay, it's built.  Have fun!

thx Jerry.

Jorge, any plans for mimetex in EPEL?
Comment 11 Kevin Fenzi 2008-01-20 16:55:48 EST
Note that there is still a broken dep on mimetex:

package: moodle - 1.8.2-1.el5.noarch from epel-testing
  unresolved deps: 
     mimetex
Comment 12 Jon Ciesla 2008-01-21 08:52:22 EST
No response here from Jorge.  How would I go about branching mimetext for EPEL,
cvsadmin request?
Comment 13 Thorsten Leemhuis 2008-01-21 12:30:30 EST
(In reply to comment #12)
> No response here from Jorge.  How would I go about branching mimetext for EPEL,
> cvsadmin request?

http://fedoraproject.org/wiki/EPEL/GuidelinesAndPolicies
Section "EPEL branching if Fedora maintainer does not react"
Comment 14 Jon Ciesla 2008-01-21 12:40:27 EST
Requested branches and EPEL maintainership.

https://bugzilla.redhat.com/show_bug.cgi?id=170225
Comment 15 Jon Ciesla 2008-01-22 08:27:13 EST
Granted, built mimetex for EL-5 and EL-4.

Note You need to log in before you can comment on or make changes to this bug.