Bug 425850 - odd behavior in the "normal-size" and maximize functions of Firefox Fedora/2.0.0.10-3.fc8
odd behavior in the "normal-size" and maximize functions of Firefox Fedora/2....
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-16 13:02 EST by Dan Maranville
Modified: 2008-01-10 07:28 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 07:28:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Running processes (11.21 KB, text/plain)
2007-12-17 06:56 EST, Dan Maranville
no flags Details
Hardware information (10.62 KB, text/plain)
2007-12-17 06:58 EST, Dan Maranville
no flags Details
Original Xorg.conf (807 bytes, text/plain)
2007-12-19 10:26 EST, Dan Maranville
no flags Details
Old Xorg log (71.55 KB, text/plain)
2007-12-19 10:27 EST, Dan Maranville
no flags Details
New Xorg log (52.59 KB, text/plain)
2007-12-19 10:28 EST, Dan Maranville
no flags Details

  None (edit)
Description Dan Maranville 2007-12-16 13:02:32 EST
Description of problem:
With either Firefox or Thunderbird the "normal-size" and maximize functions seem
to "forget" the last known state(window size) when closed at full screen mode.

Version-Release number of selected component (if applicable):
Firefox Fedora/2.0.0.10-3.fc8 and Thunderbird 2.0.0.9.

How reproducible:
Very if the following the instructions are adhered to.

Steps to Reproduce:
- Open Firefox or Thunderbird
- Maximize the window of either(Ff/Tb) (Full screen - Not F11).
- Either hit the Maximize button or double click the window bar, both work the
same, to ensure smaller size of window in alternate state.
- Maximize window again, using dbl click or Maximize button
- Close Firefox/Thunderbird in fully maximized state
- Re-open in same session or logoff and then re-open, results are the same
- Note that Firefox or Thunderbird are fully maximized upon launch
- try to "normal size" the window, via double click of the window bar or
maximize button
- An attempt to recall the last known window size will be attempted, noted by a
quick flash of previous window size. But will FAIL, and use entire usable
desktop area. Similar to being Maximized.
- Repeated clicks of the window bar or the button result in the same action.
  
Actual results:
Resize to entire available screen area and NOT the last windows state

Expected results:
Return to previous window state

Additional info:
SMOLT profile:
http://www.smolts.org/show?UUID=c60363e7-eebe-4858-a03b-a35fccf712e3
Comment 1 Christopher Aillon 2007-12-16 17:39:13 EST
What window manager are you using?
Comment 2 Dan Maranville 2007-12-16 18:05:36 EST
Gnome - Sorry about that.
Comment 3 Dan Maranville 2007-12-16 18:07:48 EST
I also just confirmed it on a fresh install of F8 on another machine.
Smolt profile:
http://www.smolts.org/show?UUID=bb7b5322-78b6-486e-ac98-94bac734f683

Also running Gnome
Comment 4 Christopher Aillon 2007-12-17 06:22:24 EST
metacity or compiz?  (e.g. are you running the cube with the neat effects?)
Comment 5 Dan Maranville 2007-12-17 06:48:48 EST
Just the default Metacity, no frills desktop.
Comment 6 Dan Maranville 2007-12-17 06:56:47 EST
Created attachment 289771 [details]
Running processes
Comment 7 Dan Maranville 2007-12-17 06:58:15 EST
Created attachment 289773 [details]
Hardware information

This is for the notebook.
Comment 8 Matěj Cepl 2007-12-19 10:02:15 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 9 Dan Maranville 2007-12-19 10:26:37 EST
Created attachment 290032 [details]
Original Xorg.conf 

This is the orig before deletion.
Comment 10 Dan Maranville 2007-12-19 10:27:30 EST
Created attachment 290033 [details]
Old Xorg log

This is the log from before the deletion of the conf file
Comment 11 Dan Maranville 2007-12-19 10:28:18 EST
Created attachment 290034 [details]
New Xorg log

This is the log file after deletion of the conf and reboot.
Comment 12 Dan Maranville 2008-01-04 08:31:52 EST
This bug is still apparent in 2.0.11
Comment 13 Matěj Cepl 2008-01-06 20:04:17 EST
Reporter, does this happen with other application than firefox/thunderbird?
Comment 14 Dan Maranville 2008-01-06 22:47:32 EST
So far I have not found any others.
Terminals, Nautilus, Gedit, Gftp, Open Office are all "OK".
Comment 15 Christopher Aillon 2008-01-09 07:30:16 EST
Matej, can you reproduce in firefox 3?
Comment 16 Matěj Cepl 2008-01-09 11:21:51 EST
(In reply to comment #15)
> Matej, can you reproduce in firefox 3?

Actually, I cannot. I have experienced this with F8, but I cannot reproduce it now.

Note You need to log in before you can comment on or make changes to this bug.