Bug 425852 - g-p-m causes moniter flickering when changing brightness
g-p-m causes moniter flickering when changing brightness
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-16 14:05 EST by Yaakov Nemoy
Modified: 2013-03-05 22:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-30 16:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yaakov Nemoy 2007-12-16 14:05:58 EST
Description of problem:
When the laptop's power is plugged and unplugged, g-p-m tries to fade the
brightness setting from 100% to 50%.  This laptop, a Gateway MX6391 can only
display specific percentages of brightness.  When it gets a number it can't
handle, it just turns the backlight off.

This fading causes the monitor to blink on and off while trying to change.  This
flickering also seems to cause stuttering in music playback from Amarok.

Version-Release number of selected component (if applicable):
Source       : gnome-power-manager-2.20.0-6.fc8.src.rpm
Build Time   : Tue Oct 16 17:01:43 2007



How reproducible:
Happens everytime on this machine.  You need a Gateway MX6391 to reproduce it.


Steps to Reproduce:
1. Plug laptop in
2. Unplug laptop
3. Do while amarok plays music
  
Actual results:
The monitor flickers and the music stutters

Expected results:
The monitor should either drop directly down to 50% or cycle through the known
working percentages, possibly provided by hal-quirks.
The music should not stutter.

Additional info:

Not sure what you need, but here is my Smolt link
http://www.smolts.org/show?UUID=e2598b4e-aa21-4905-8fa8-589d3734b5a1
Comment 1 Richard Hughes 2008-04-30 05:25:28 EDT
This I think is a kernel bug, where the number of correct states was not being
reported correctly. Does this now work with a more up to date kernel?
Comment 2 Yaakov Nemoy 2008-04-30 16:01:46 EDT
I can't test this anymore, since the laptop in question has a massive crack
running through the screen.  I'm going to declare this closed, only because of
that.  That laptop's been delegated to Folding.

Note You need to log in before you can comment on or make changes to this bug.