Bug 425866 - endless greeter crash loop
endless greeter crash loop
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-16 18:02 EST by Josef Kubin
Modified: 2007-12-18 09:58 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 09:58:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenShot (12.07 KB, image/png)
2007-12-16 18:02 EST, Josef Kubin
no flags Details
No, no I don't want to click 6-times OK button again! A disable button wanted. (4.16 KB, image/png)
2007-12-16 18:04 EST, Josef Kubin
no flags Details

  None (edit)
Description Josef Kubin 2007-12-16 18:02:10 EST
Description of problem:
Suddenly greeter application has decided to crash, and there is no way how to
disable endless loop. Work on VC is hard and anoying because of dialog with OK
button.

Do you think that after 6 attempts it suddenly starts?
(suddenly something fixes itself)
Unfortunatelly after 2 minute timeut starts torment again ...
After 10 minuts of described torture a new unexperienced user decides to delete
Fedora 8 from his hard drive because of this.

Version-Release number of selected component (if applicable):
gdm-2.20.2-2.fc8

How reproducible:
always

At least disable loop button is fix for the problem.
Comment 1 Josef Kubin 2007-12-16 18:02:10 EST
Created attachment 289732 [details]
screenShot
Comment 2 Josef Kubin 2007-12-16 18:04:08 EST
Created attachment 289733 [details]
No, no I don't want to click 6-times OK button again! A disable button wanted.
Comment 3 Ray Strode [halfline] 2007-12-17 11:43:13 EST
/sbin/init 3 may help somewhat.

fwiw, in F-9, we're getting rid of the curses thing entirely.


why is gdm crashing though? can you attach /var/log/messages ?
Comment 4 Josef Kubin 2007-12-18 00:37:11 EST
I would like to attach mentioned log file, but unfortunatelly vmware image with
Fedora 8 went to hell yesteday ...

I know (because I know from past), `/sbin/init 3` is solution for the situation,
but try to imagine a nervous Linux beginner without google and without time, how
can he guess that the runlevel change stops endless loop ...

My bug report was actually about wrong logical flow without end. Endless loop
without "special" button isn't good solution as reaction on unrecoverable situation.
Comment 5 Josef Kubin 2007-12-18 02:07:35 EST
https://bugzilla.redhat.com/attachment.cgi?id=289733

At least similar help sentence expected:

"To fix your problem change runlevel to 3 `/sbin/init 3`, back to graphics
environment change the runlevel to 5 `/sbin/init 5`.
Comment 6 Ray Strode [halfline] 2007-12-18 09:58:11 EST
We're going to get rid of the text mode dialogs entirely in F9.  Probably not
going to change anything in F8 (changing strings would require getting
translations, etc).

Unfortunately, for a lot of users, even learning about `/sbin/init 3' won't be
enough to recover the system.  It's a pretty hard problem  (No doubt the looping
is silly though, we've taken that out for F9).

Note You need to log in before you can comment on or make changes to this bug.