Bug 425868 - Anaconda exception list.index(x): x not in list
Anaconda exception list.index(x): x not in list
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-16 18:19 EST by John Klein
Modified: 2007-12-16 23:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-16 23:11:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback file (153.37 KB, text/plain)
2007-12-16 18:21 EST, John Klein
no flags Details
Kickstart file (2.29 KB, text/plain)
2007-12-16 18:22 EST, John Klein
no flags Details

  None (edit)
Description John Klein 2007-12-16 18:19:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.12) Gecko/20071019 Fedora/1.5.0.12-5.fc6 Firefox/1.5.0.12

Description of problem:
Kickstart install via PXE.
System uses nVidia nForce4 SLI chipset.  Reading the traceback file, it looks like anaconda isn't able to write the MBR.
Same system has worked with FC6 (and FC5).

Version-Release number of selected component (if applicable):
anaconda 11.3.0.50

How reproducible:
Always


Steps to Reproduce:
1. Install f8 using PXE or DVD (always used same http:// install tree)
2. Usually partition drives as dm raid 1, but fails regardless
3.

Actual Results:
Same traceback regardless of test conditions.  Tried booting other media, not using RAID, wiiping the MBR from the two drives in question, swaping the drive boot order, resetting the machine's BIOS back to default values...

Expected Results:
Grub should have installed to the primary drive's mbr, and not generated a fatal exception.

Additional info:
Other nForce4 SLI machines can install from this same installation tree, using the same kickstart file.
Comment 1 John Klein 2007-12-16 18:21:10 EST
Created attachment 289734 [details]
traceback file

Here's what anaconda copied
Comment 2 John Klein 2007-12-16 18:22:53 EST
Created attachment 289735 [details]
Kickstart file

Just for fun, here's my kickstart file
Comment 3 Jon Stanley 2007-12-16 19:03:40 EST
In the ks file, all of the partitioning information is commented out and it
looks like a "real" ks file as opposed to one that anaconda spit out.  Is this
an oversight?
Comment 4 John Klein 2007-12-16 23:11:15 EST
On futher digging, this is just "stupid user error"
The kickstart file is "real" and the line:

bootloader --location=mbr --driveorder=sda --append="rhgb quiet"

is what was causing my problems.  If I omit the "--driveorder=sda" parameter,
everything works perfectly.

Sorry for the spurious report, and kudos on your fast response to it! :-)

Note You need to log in before you can comment on or make changes to this bug.