Spec URL: http://repo.calcforge.org/f9/kde4-decoration-native-quarticurve-kwin.spec
SRPM URL: http://repo.calcforge.org/f9/kde4-decoration-native-quarticurve-kwin-0.0-0.1.beta3.fc8.src.rpm
Quarticurve-KWin is an unofficial port of Red Hat's Bluecurve KWin 3 decoration
(taken out of redhat-artwork 7.0.0) to KDE 4. This port is NOT endorsed or
supported by Red Hat.
This package is targeted at F9+ ONLY. It replaces the bluecurve-kwin-theme which is useless in KDE 4.
In case that it isn't obvious, the Contribution under the CLA here is supposed to be the packaging, not the upstream source code, even though I happen to be upstream. (The upstream code is GPL v2, so no licensing issues there.)
I can review this.
Scratch build submitted:
Hrm, seems to be a problem using it (the scratch build anyway), systemsettings
systemsettings: symbol lookup error: /usr/lib64/kde4/kwin3_quarticurve.so:
undefined symbol: _ZN7QPixmapC2ERK5QSizeNS_4TypeE
I'll continue to the review on other items.
kde4-decoration-native-quarticurve-kwin.x86_64: W: obsolete-not-provided
kde4-decoration-native-quarticurve-kwin.x86_64: W: filename-too-long-for-joliet
The name *is* kinda long, why include "decoration-native'? (or maybe that's from
the proposed kde naming spec)?
speaking of names, including 'kde3' in the name seems a bit confusing too. ?
Packaging-wise, the spec looks simple, clean enough.
Address/respond-to the "not working" and "naming" issues (worksforme, forget it,
respectfully, are acceptable. :) ), and I'll approve this.
The name is from the naming spec (with the additional proposal of
specifying "kde4" to make it clear), it's ridiculously long indeed. Any better
suggestion? (If so, we should fix the spec.)
The unresolved symbol is definitely a bug, I'll need some time to debug it.
Oh and for the .so name, KWin 4.0 uses kwin3_*.so plugin names for its own
plugins too. I know it's silly, but I'm just doing what upstream does.
Ick, I guess that explains why I'm seeing double entries in systemsettings
(kde-4.0) with kdebase3 installed. doh. Looks like one more thing to omit.
It turns out the "undefined symbol: _ZN7QPixmapC2ERK5QSizeNS_4TypeE" error
actually came from building against Qt 4.3.3 and running with 4.4 TP1
(something which is supposed to work, I filed an issue report at Trolltech
about the binary compatibility breakage), when running with Qt 4.3.3, this is
not an issue (we discussed this on IRC).
This leaves the issue of the package name: I'm OK with renaming the package to
whatever it should be named, but what should I rename it to? ;-)
SHOULD: Use a shorter/better pkg name. I'll leave the naming to your best
judgment (maybe simply quarticurve or quarticurve-kwin?). Note: this should be
decided before the cvs module is created, of course. :)
SHOULD: remove the "not endorsed by Red Hat" phrase from the description. It
doesn't add any value (besides, being "unofficial" is already mentioned).
I don't see any blockers here, and bonus points for being upstream. The package
here is simple and clean.
OK, I'll rename the package and retouch the description during/after import.
New Package CVS Request
Package Name: quarticurve-kwin-theme
Short Description: Unofficial port of the Bluecurve KWin decoration to KDE 4
Cvsextras Commits: yes
Well, if you intend to rename it, it would be best to do so before adding it to
CVS. Is this the final name you want (in comment #12?)
Yes, the name in the CVS request is already the one I want to rename it to.
ok, Just wanted to make sure.