Bug 425874 - Thinkpad brightness controls don't work in X
Summary: Thinkpad brightness controls don't work in X
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2007-12-17 01:24 UTC by Chris Adams
Modified: 2009-01-09 05:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2009-01-09 05:31:49 UTC

Attachments (Terms of Use)

Description Chris Adams 2007-12-17 01:24:51 UTC
I have installed F8 on a Thinkpad Z60m and loaded all updates.  The Fn+HOME and
Fn+END do not change the brightness in X.  If I switch to a text console, they
work (but switching back to X goes back to the previous brightness).  Also,
echoing into /proc/acpi/ibm/brightness does not work; depending on the initial
state, the file doesn't exist and the following is in the kernel log:

thinkpad_acpi: CMOS NVRAM (6) and EX (0) do not agree on display brightness level

This all works in FC6 on the same notebook.

Comment 1 Chris Adams 2007-12-17 17:36:07 UTC
I updated to xorg-x11-drv-ati-6.7.196-4.fc8 from updates-testing, and I have
brightness hot-keys back.  thinkpad_acpi is still unhappy (same error and no
/proc/acpi/ibm/brightness), but the functionality works in X.  The Bluetooth
enable/disable doesn't work from Fn+F5, but does with /proc/acpi/ibm/bluetooth,
so there is still some "oddness" with thinkpad_acpi (stuff that worked before).

Comment 2 Bug Zapper 2008-11-26 09:02:14 UTC
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 

Comment 3 Bug Zapper 2009-01-09 05:31:49 UTC
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.