Bug 425879 - [RFE] allow IPv6 addresses without http:// prefix
Summary: [RFE] allow IPv6 addresses without http:// prefix
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lynx
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-17 03:32 UTC by shrek-m
Modified: 2019-01-13 22:15 UTC (History)
1 user (show)

Fixed In Version: lynx-2.8.7-4.fc14
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-07 23:05:36 UTC


Attachments (Terms of Use)
patch which adds desired feature (2.20 KB, patch)
2008-07-11 12:45 UTC, Jiri Moskovcak
no flags Details | Diff
proposed patch (1.60 KB, patch)
2010-04-07 15:59 UTC, Kamil Dudka
kdudka: review? (dickey)
Details | Diff

Description shrek-m 2007-12-17 03:32:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc7 Firefox/2.0.0.10

Description of problem:
no IPv6 support in current version

Version-Release number of selected component (if applicable):
lynx-2.8.6-10.fc9

How reproducible:
Always


Steps to Reproduce:
1. $ lynx [ipv6]

Actual Results:
#1
$ LANG=C lynx http://[2001::101]
Looking up [2001
Unable to locate remote host [2001.
Alert!: Unable to connect to remote host.
lynx: Can't access startfile http://[2001/

#2
$ LANG=C lynx [2001::101]
Alert!: Unsupported URL scheme!
lynx: Start file could not be found or is not text/html or text/plain
      Exiting...
#3
$ LANG=C lynx 2001::101
Alert!: Unsupported URL scheme!
lynx: Start file could not be found or is not text/html or text/plain
      Exiting...
#4
$ LANG=C lynx http://2001::101
Looking up 2001
Making HTTP connection to 2001
Alert!: Unable to connect to remote host.
lynx: Can't access startfile http://2001/


Expected Results:
#1 #2 should work as expected, eg. elinks, firefox support ipv6

elinks http://[2001::101]
elinks [2001::101]
firefox http://[2001::101]
firefox [2001::101]


Additional info:
#3 #4 afaik should not be ok for a browser cause of "ip::v6:port"

telnet and other progs are ok without the "[]"
'telnet 2001::101 80'
other progs use "-6" eg. 'nmap -6 -p80 2001::101'
other progs have a "prog6" version, eg. 'ping6 2001::101'


iirc there exist rfc-conform examples explicit for documentation,
something like  2001:db8::1 or similiar

eg. http://tools.ietf.org/html/rfc4291

Comment 1 Jon Stanley 2008-04-23 20:29:41 UTC
Adding FutureFeature keyword to RFE's.

Comment 2 Jiri Moskovcak 2008-07-11 12:45:14 UTC
Created attachment 311568 [details]
patch which adds desired feature

This patch should add possibility to specify the ipv6 address as cmdline
argument.
e.g:
$ ./lynx [::1]
$ ./lynx [::1]:80

Comment 3 Jiri Moskovcak 2008-07-11 12:55:17 UTC
Thomas,
can you please take a look at this patch and if it's ok, would you commit it to
upstream?

Comment 4 Kamil Dudka 2010-04-07 15:59:34 UTC
Created attachment 405011 [details]
proposed patch

Comment 5 Thomas E. Dickey 2010-04-07 20:34:44 UTC
will check, this evening (2.8.7 supposedly fixes this problem).

Comment 6 Kamil Dudka 2010-04-07 21:07:45 UTC
Thanks in advance!

The patch applies on top of 2.8.7.

Comment 7 Thomas E. Dickey 2010-04-07 22:24:32 UTC
I was recalling a related but different issue:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=180654

Comment 8 Kamil Dudka 2010-04-07 22:34:16 UTC
Thank you for the link.  I can confirm it works with 2.8.7.  On top of that, the proposed patch makes it working without the http:// prefix.

Comment 9 Thomas E. Dickey 2010-04-07 22:53:19 UTC
works for me (thanks)

Comment 10 Kamil Dudka 2010-04-07 23:05:36 UTC
built as lynx-2.8.7-4.fc14

It would be great to see the patch in next release of lynx.

Comment 11 Thomas E. Dickey 2010-04-08 08:12:17 UTC
I have it in my ongoing changes, see

ftp://invisible-island.net/temp/lynx2.8.8dev.2f.patch.gz

I've been slow on dev.3 since I've been setting up a new development
machine, working on ports for lynx, ncurses, vile, ded and xterm,
which seem stable now...

Comment 12 Kamil Dudka 2010-04-08 09:06:18 UTC
(In reply to comment #11)
> ftp://invisible-island.net/temp/lynx2.8.8dev.2f.patch.gz

It seems good.  Looking forward for the next snapshot and wishing good luck!


Note You need to log in before you can comment on or make changes to this bug.