Bug 42590 - kdeadmin-2.2A2: kuser missing hicolor toolbar icons
kdeadmin-2.2A2: kuser missing hicolor toolbar icons
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kdeadmin (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-28 12:01 EDT by j. alan eldridge
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-28 12:01:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j. alan eldridge 2001-05-28 12:01:26 EDT
Description of Problem:

The icons on the kuser toolbar are missing. That's 'cause they're 
missing from the source tarball.

It could be patched up in the source dirs, but frankly, it's easier to 
fix this in the spec file, considering sooner or later somebody at KDE's 
hideout will notice this and deal with it officially.

Watch the web-form-mangled lines below. It's easy enough to see what to 
do though. Just dupe the directory locolor to hicolor. You could even do 
it with a symlink, but that might confuse rpm down the road when a new 
package comes out that has dirs.

[alane@wwweasel SPECS]$ diff -ru kdeadmin.spec.or kdeadmin.spec
--- kdeadmin.spec.or    Tue May 22 08:47:07 2001
+++ kdeadmin.spec       Mon May 28 11:52:38 2001
@@ -94,6 +94,10 @@
 mv $RPM_BUILD_ROOT/usr/bin/*kontrol-panel 
$RPM_BUILD_ROOT/usr/bin/kontrol-panel
 mv $RPM_BUILD_ROOT/etc/X11/applnk/System/kontrol-panel.desktop 
$RPM_BUILD_ROOT/usr/share/applnk/System
 
+#  fix missing icons
+cp -a $RPM_BUILD_ROOT/usr/share/apps/kuser/icons/locolor \
+        $RPM_BUILD_ROOT/usr/share/apps/kuser/icons/hicolor
+
 # remove dupes from kdebase
 rm -f 
$RPM_BUILD_ROOT/%{prefix}/share/icons/locolor/16x16/apps/{package,printer}.png 

Shit. I mean, you run the app, the toolbar's all whacked out. How do you 
*not* notice this? (A. When you're not wiping clean between test 
installs.)
Comment 1 Bernhard Rosenkraenzer 2001-08-09 09:40:23 EDT
This was fixed some time between then and now.

Note You need to log in before you can comment on or make changes to this bug.