Bug 42592 - certain X activity locks up thinkpad t20.
certain X activity locks up thinkpad t20.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-28 12:45 EDT by Ed Price
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-28 18:06:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config-4 (3.69 KB, text/plain)
2001-05-28 12:47 EDT, Ed Price
no flags Details
XFree86.0.log (22.34 KB, text/plain)
2001-05-28 12:47 EDT, Ed Price
no flags Details

  None (edit)
Description Ed Price 2001-05-28 12:45:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
Running x11perf, dragging the scrollbar in mozilla, letting the 
screensavers run: all of these are pretty good at locking up my machine (a 
thinkpad t20).

How reproducible:
Always

Steps to Reproduce:
1. install redhat 7.1 in "laptop" mode on thinkpad t20.
2. log in.
3. startx
4. turn off screensavers in gnome control center.
5. x11perf -all
	

Actual Results:  machine locks up hard.  no response to keyboard, mouse, 
or ping.  requires power off, reboot, fsck, etc.   really sux. :(

(to clarify: it does not lock up immediately.  sometimes it takes a few 
seconds, sometimes a minute.)

Expected Results:  continued operation, lots of X11 performance data.

Additional info:

IIRC my thinkpad t20 is a model "2647-84U".
700 MHz, 256 MB, Savage IX 8MB, 1024x768.
it has a cisco aironet 340 wireless LAN card installed too.
but i removed the card and it made no difference.

in addition to trying stock redhat 7.1 right out of the box (i re-
installed it from scratch just to verify i hadn't done something wrong to 
cause the problem), i tried using XFree86-4.0.3-11, XFree86-4.0.3-16 (?), 
and, most recently, the latest from rawhide, XFree86-4.0.99.900-0.2.1 
(with Mesa-3.4.1-1).  also i tried using different version of gcc.  also i 
tried kernel-2.4.3-7 from rawhide, as well as "standard" (non-redhat) 
linux-2.4.4.  BTW all packages were downloaded in .src.rpm form, compiled 
with "rpm --rebuild" and installed with "rpm -Fv".  i didn't try ALL 
combinations of ALL of these, but i've been struggling with this for a 
while so i did cover a fair number...  no luck in any case.

currently i am using stock redhat 7.1 + XFree86-4.0.99.900-0.2.1, Mesa-
3.4.1, gcc-2.96-85, kernel-2.4.3-7.  i also tried disabling DRI by 
commenting out 'Load "dri"' in XF86Config-4.

any assistance would be appreciated; thanks!!!

PS a while back i had some weird problems (unreproducible ICEs) with gcc, 
but that turned out to be bad memory.  i ran "memtest86" and it reported 
errors.  i had the bad memory replaced and now memtest86 does not report 
errors, and i've had no more weird problems with gcc.
Comment 1 Ed Price 2001-05-28 12:47:16 EDT
Created attachment 19831 [details]
XF86Config-4
Comment 2 Ed Price 2001-05-28 12:47:54 EDT
Created attachment 19832 [details]
XFree86.0.log
Comment 3 Mike A. Harris 2001-05-28 15:13:09 EDT
Dave, isn't this the same laptop that you have?  Could you perhaps
suggest something that might help?

My suggestion would first off be to get completely rid of the 4.0.99.*
that you got from Rawhide.  It is completely broken, DRI doesn't work,
Mesa is mismatched and numerous other problems.  It is a first shot alpha
build of an alpha quality software package.  I don't consider any bug
reports on it valid as the package is not really meant to be in rawhide.
I accidentally built it in rawhide.  All of the 4.0.3-* releases should
just be installed from binary packages for the best compatibility.

I recommend installing 4.0.3-16 or later (but not 4.0.99.*), and configure
it with:  Xconfigurator --preferxf4 --nodri
Comment 4 Ed Price 2001-05-28 18:06:12 EDT
thanks; i will attempt to do as you say.  but already i have a problem. :) 
where can i get a binary RPM of XFree86-4.0.3-16?  i don't see it on rawhide or 
people.redhat.com/mharris.  (I have a source RPM from before, but I never 
downloaded the binary RPM.)
Comment 5 Mike A. Harris 2002-03-16 10:39:11 EST
Savage lockup problems are reported to be fixed in XFree86 4.2.0, which
is in rawhide and will be in our next release of Red Hat Linux.
Comment 6 Ed Price 2002-03-16 15:43:34 EST
thanks for the info; i really appreciate it!

BTW, i finally was able to swap hardware, just recently
when my laptop hard drive failed.  i have a new laptop
(same exact model) running (vanilla, with updates) redhat
7.2 and i was quite thrilled when i tried "x11perf -all"
and it actually ran to completion no problem.

however, it still freezes when running screensavers.
now that i've disabled screensaver (whatever comes as
default in gnome), i have had no more lockups.

i'll look forward to the new releases and possibly check
out rawhide...  thanks again :)


Note You need to log in before you can comment on or make changes to this bug.