Bug 425946 - Fedora Core 8 fails to install on Athlon XP 3200+
Fedora Core 8 fails to install on Athlon XP 3200+
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
athlon Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-17 06:33 EST by Andrew Billyard
Modified: 2008-08-06 16:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-08-06 16:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrew Billyard 2007-12-17 06:33:57 EST
Description of problem:  Anaconda always fails to install (right after media
check is completed), with "abnormally aborted [1/1]" message.  Have tried all
the command line options such as nopcmcia, ide=nodma, noapic, etc all with the
same results.  Currently have FC 5 (which installed without a single hiccough).

Version-Release number of selected component (if applicable): anaconda

How reproducible: Always

Steps to Reproduce:
1. Insert FC 8 DVD
2. Choose "Install" method (or text only mode, either way)
3. Perform media check
4. Watch system exit abnormally and tell user to reboot
Actual results:

Expected results:

Additional info:
AMD Athlon XP 3200+
1 GB of RAM (PC3200, 400MHz)
Motherboard: Mach Speed's V600DAP VIA KT600
Comment 1 Jeremy Katz 2007-12-17 11:52:20 EST
What's the last line on tty3 when it segfaults?  Also, can you provide the
backtrace that you get?
Comment 2 Andrew Billyard 2007-12-17 13:50:59 EST
Jeremy, is there an easy way to get the backtrace that you need?
Comment 3 Chris Lumens 2007-12-18 14:11:39 EST
If it's just printing up a column of numbers, you can write them down and type
them up into this bug report, or you can take a picture and attach it.
Comment 4 Andrew Billyard 2007-12-18 20:07:39 EST
OK, here is the output:

Running anaconda, the Fedora system installer - please wait...
install exited abnormally [1/1]
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
   /mnt/runtime done
   disabling /dev/loop0
   /proc/bus/usb done
   /proc done
   /dev/pts done
   /sys done
   /tmp/ramfs done
   /mnt/source done
   /selinux done
you may safely reboot your system

Comment 5 Andrew Billyard 2007-12-22 14:21:56 EST
Some more debugging info (just found these screens).  <Ctrl><Alt><F3> reveals:

WARNING: module import of fedora failed: <type 'exceptions.ImportError'>
WARNING: module import of rhel failed: <type 'exceptions.ImportError'>
INFO: using baseinstallclass as base
INFO: anaconda called with cmdline = ['/usr/bin/anaconda', '-
m', 'cdrom://scd0:/mnt/source', '--graphical', '--selinux']
INFO: Display mode = g
INFO: Method = cdrom://scd0:/mnt/source
INFO anaconda floppy defice fd0
WARNING: DISPLAY variable not set.  Starting text mode!


And <Ctrl><Alt><F4> reveals:

<3>SQUASHFS error: sb_bread failed reading block 0x6ef7
<3>SQUASHFS error: unable to read page, block 1bbb3ff, size 2848

(These two lines fill the whole screen)

Comment 6 Andrew Billyard 2007-12-29 23:02:51 EST
Hi All,  This is showing up as a low priority, but I cannot install FC8 (or FC7
for that matter...just tried that and got the same results).  As such, I don't
believe that this is a low priority!  I'm sniffing for other linux flavours here
if I can't get this to work.
Comment 7 Andy Lindeberg 2008-06-03 13:45:38 EDT
Have you tried installing FC9?

Note You need to log in before you can comment on or make changes to this bug.