Bug 425966 - /usr/bin/ld internal error (../../bfd/merge.c line 861 in _bfd_merged_section_offset)
/usr/bin/ld internal error (../../bfd/merge.c line 861 in _bfd_merged_section...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 09:39 EST by Hans Ulrich Niedermann
Modified: 2008-11-19 06:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-19 06:57:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ulrich Niedermann 2007-12-17 09:39:01 EST
Description of problem:

/usr/bin/ld: BFD version 2.17.50.0.18-1 20070731 internal error, aborting at
../../bfd/merge.c line 861 in _bfd_merged_section_offset

/usr/bin/ld: Please report this bug.

Version-Release number of selected component (if applicable):

  binutils-2.17.50.0.18-1

How reproducible:

  I cannot reproduce it.

Steps to Reproduce:
  No idea.

  I did a "make -j" build of an automake/non-libtool based package with multiple
C source files, aborted it with Ctrl-C, and then ran "make -j" again. The second
run produced that error.

  I could not reproduce the behaviour, however.
  
Actual results:
N/A

Expected results:
N/A

Additional info:
I'll keep my eyes open in case it happens again, but perhaps you can find
something in the sourcecode even without a test case triggering the problem.
Comment 1 Hans Ulrich Niedermann 2008-07-16 11:19:05 EDT
As I am seeing some activity here, an update: It has not happened again.
Comment 2 Hans Ulrich Niedermann 2008-10-28 09:44:52 EDT
I have not seen the issue again.
Comment 3 Nick Clifton 2008-11-19 06:57:35 EST
Since this bug is not reproducible (and it refers to an old version of the sources) I am going to close it.

Note You need to log in before you can comment on or make changes to this bug.