Bug 425969 - network restart with DHCP breaks
network restart with DHCP breaks
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 10:03 EST by Stepan Kasal
Modified: 2014-03-16 23:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-17 11:28:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sleep during network restart (360 bytes, patch)
2007-12-17 10:03 EST, Stepan Kasal
no flags Details | Diff

  None (edit)
Description Stepan Kasal 2007-12-17 10:03:45 EST
Description of problem:

I have a usual setup: one wired eth0 card.
When I have problems with network, "service network restart" fails, while
"service network stop" and "service network start" always does work.  (The
starting conditions were the same in both cases.)

The error message says that "another instance of dhclient is running".

Version-Release number of selected component (if applicable):
8.60-1

I think the manual variant works because of the delay caused by typing "service
network start" on the keyboard.

Would it make sense to wait a second or two between the start and stop?
(Attached please find a proposed patch.)
Comment 1 Stepan Kasal 2007-12-17 10:03:45 EST
Created attachment 289781 [details]
sleep during network restart
Comment 2 Bill Nottingham 2007-12-17 13:33:46 EST
If there's really a delay issue here, that should be fixed at the source rather
than an arbitrary sleep. Needs more investigation.
Comment 3 Ricky Ng-Adam 2008-01-01 22:59:53 EST
Would this be related? Restart are always reported as "FAILED" but network is
working correctly anyway? The difference is that stop/start doesn't help here.

dhclient-3.0.6-10.fc8
initscripts-8.60-1

[root@localhost ~]# ps -eaf | grep 5671
root      5671     1  0 22:55 ?        00:00:00 /sbin/dhclient -d -sf
/usr/libexec/nm-dhcp-client.action -pf /var/run/dhclient-eth0.pid -lf
/var/run/dhclient-eth0.lease eth0
root      5720  3046  0 22:55 pts/1    00:00:00 grep 5671
[root@localhost ~]# /etc/init.d/network stop
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
[root@localhost ~]# ps -eaf | grep 5671
root      6002  3046  0 22:55 pts/1    00:00:00 grep 5671
[root@localhost ~]# ps -eaf | grep dhclient
root      6005  3046  0 22:55 pts/1    00:00:00 grep dhclient
[root@localhost ~]# /etc/init.d/network start
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:  
Determining IP information for eth0...dhclient(6170) is already running - exiting. 
This version of ISC DHCP is based on the release available
on ftp.isc.org.  Features have been added and other changes
have been made to the base software release in order to make
it work better with this distribution.
Please report for this software via the Red Hat Bugzilla site:
    http://bugzilla.redhat.com
exiting.
 failed.
                                                           [FAILED]
Comment 4 Bug Zapper 2008-05-14 00:12:36 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 iarly selbir 2009-03-14 21:15:28 EDT
Thank you for your report.

This bug is very old.

is this problem happening yet?

give us feedback.

Thanks

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Stepan Kasal 2009-04-17 11:28:32 EDT
(In reply to comment #5)
> is this problem happening yet?

Thank you for your cleanup work.

Unfortunately, I'm not able to test this right now.
Let's close it.
Comment 7 Stepan Kasal 2009-04-17 13:51:47 EDT
Actually, a short power outage encouraged me to do a quick test; I cannot reproduce it any more.  Let's suppose it's fixed.

Note You need to log in before you can comment on or make changes to this bug.