Bug 425972 - [RHEL 5] soft lockup<IRQ> [<ffffffff802aaa80>] softlockup_tick+0xd5/
[RHEL 5] soft lockup<IRQ> [<ffffffff802aaa80>] softlockup_tick+0xd5/
Status: CLOSED DUPLICATE of bug 250994
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1.z
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 10:12 EST by Subhendu Ghosh
Modified: 2009-12-14 16:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 10:27:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Subhendu Ghosh 2007-12-17 10:12:23 EST
Description of problem:
System logs multiple soft lockup messages and then hangs.

Version-Release number of selected component (if applicable):
Dell Precision 690n
RHEL 5.1
2.6.18-53.1.4.el5xen #1 SMP


Dec 17 09:03:35 thies kernel: BUG: soft lockup detected on CPU#3!
Dec 17 09:03:35 thies kernel: 
Dec 17 09:03:35 thies kernel: Call Trace:
Dec 17 09:03:35 thies kernel:  <IRQ>  [<ffffffff802aaa80>] softlockup_tick+0xd5/0xe7
Dec 17 09:03:35 thies kernel:  [<ffffffff8026cb4a>] timer_interrupt+0x396/0x3f2
Dec 17 09:03:35 thies kernel:  [<ffffffff80210afe>] handle_IRQ_event+0x2d/0x60
Dec 17 09:03:35 thies kernel:  [<ffffffff802aae08>] __do_IRQ+0xa4/0x105
Dec 17 09:03:35 thies kernel:  [<ffffffff8028870f>] _local_bh_enable+0x61/0xc5
Dec 17 09:03:35 thies kernel:  [<ffffffff8026a90e>] do_IRQ+0xe7/0xf5
Dec 17 09:03:35 thies kernel:  [<ffffffff803965ae>] evtchn_do_upcall+0x86/0xe0
Dec 17 09:03:35 thies kernel:  [<ffffffff8025d8ce>] do_hypervisor_callback+0x1e/0x2c
Dec 17 09:03:35 thies kernel:  <EOI>  [<ffffffff802063aa>]
hypercall_page+0x3aa/0x1000
Dec 17 09:03:35 thies kernel:  [<ffffffff802063aa>] hypercall_page+0x3aa/0x1000
Dec 17 09:03:35 thies kernel:  [<ffffffff8026be87>] raw_safe_halt+0x84/0xa8
Dec 17 09:03:35 thies kernel:  [<ffffffff80269453>] xen_idle+0x38/0x4a
Dec 17 09:03:35 thies kernel:  [<ffffffff80247ba9>] cpu_idle+0x97/0xba
Dec 17 09:03:35 thies kernel: 

Dec 17 09:12:39 thies kernel: BUG: soft lockup detected on CPU#3!
Dec 17 09:12:39 thies kernel: 
Dec 17 09:12:39 thies kernel: Call Trace:
Dec 17 09:12:39 thies kernel:  <IRQ>  [<ffffffff802aaa80>] softlockup_tick+0xd5/0xe7
Dec 17 09:12:39 thies kernel:  [<ffffffff8026cb4a>] timer_interrupt+0x396/0x3f2
Dec 17 09:12:39 thies kernel:  [<ffffffff80210afe>] handle_IRQ_event+0x2d/0x60
Dec 17 09:12:39 thies kernel:  [<ffffffff802aae08>] __do_IRQ+0xa4/0x105
Dec 17 09:12:39 thies kernel:  [<ffffffff8028870f>] _local_bh_enable+0x61/0xc5
Dec 17 09:12:39 thies kernel:  [<ffffffff8026a90e>] do_IRQ+0xe7/0xf5
Dec 17 09:12:39 thies kernel:  [<ffffffff803965ae>] evtchn_do_upcall+0x86/0xe0
Dec 17 09:12:39 thies kernel:  [<ffffffff8025d8ce>] do_hypervisor_callback+0x1e/0x2c
Dec 17 09:12:39 thies kernel:  <EOI>  [<ffffffff802063aa>]
hypercall_page+0x3aa/0x1000
Dec 17 09:12:39 thies kernel:  [<ffffffff802063aa>] hypercall_page+0x3aa/0x1000
Dec 17 09:12:39 thies kernel:  [<ffffffff8026be87>] raw_safe_halt+0x84/0xa8
Dec 17 09:12:39 thies kernel:  [<ffffffff80269453>] xen_idle+0x38/0x4a
Dec 17 09:12:39 thies kernel:  [<ffffffff80247ba9>] cpu_idle+0x97/0xba
Dec 17 09:12:39 thies kernel:
Comment 1 Subhendu Ghosh 2007-12-17 10:15:46 EST
Additionally - boot log shows Invalid checksum error

Dec 17 08:21:19 thies syslogd 1.4.1: restart.
Dec 17 08:21:19 thies kernel: klogd 1.4.1, log source = /proc/kmsg started.
Dec 17 08:21:19 thies kernel: Bootdata ok (command line is ro
root=/dev/VolGroup00/LVroot rhgb quiet)
Dec 17 08:21:19 thies kernel: Linux version 2.6.18-53.1.4.el5xen
(brewbuilder@hs20-bc2-3.build.redhat.com) (gcc version 4.1.2 200706
26 (Red Hat 4.1.2-14)) #1 SMP Wed Nov 14 10:52:01 EST 2007
Dec 17 08:21:19 thies kernel: BIOS-provided physical RAM map:
Dec 17 08:21:19 thies kernel:  Xen: 0000000000000000 - 000000026e872000 (usable)
Dec 17 08:21:19 thies kernel: DMI 2.3 present.
Dec 17 08:21:20 thies kernel:   >>> ERROR: Invalid checksum
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x01] lapic_id[0x00] enabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x02] lapic_id[0x06] enabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x03] lapic_id[0x01] enabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x04] lapic_id[0x07] enabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x05] lapic_id[0x00] disabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x06] lapic_id[0x01] disabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x07] lapic_id[0x02] disabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC (acpi_id[0x08] lapic_id[0x03] disabled)
Dec 17 08:21:20 thies kernel: ACPI: LAPIC_NMI (acpi_id[0xff] high edge lint[0x1])
Dec 17 08:21:20 thies kernel: ACPI: IOAPIC (id[0x08] address[0xfec00000]
gsi_base[0])
Dec 17 08:21:20 thies kernel: IOAPIC[0]: apic_id 8, version 32, address
0xfec00000, GSI 0-23
Dec 17 08:21:20 thies kernel: ACPI: IOAPIC (id[0x09] address[0xfec80000]
gsi_base[24])
Dec 17 08:21:20 thies kernel: IOAPIC[1]: apic_id 9, version 32, address
0xfec80000, GSI 24-47
Dec 17 08:21:20 thies kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2
dfl dfl)
Dec 17 08:21:20 thies audispd: starting audispd
Dec 17 08:21:20 thies kernel: ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9
high level)
Dec 17 08:21:20 thies kernel: Setting APIC routing to xen
Dec 17 08:21:20 thies kernel: Using ACPI (MADT) for SMP configuration information
Dec 17 08:21:20 thies kernel: Allocating PCI resources starting at d1000000
(gap: d0000000:10000000)
Dec 17 08:21:20 thies kernel: Built 1 zonelists.  Total pages: 2549874
Dec 17 08:21:20 thies kernel: Kernel command line: ro
root=/dev/VolGroup00/LVroot rhgb quiet
Dec 17 08:21:20 thies kernel: Initializing CPU#0
Dec 17 08:21:20 thies kernel: PID hash table entries: 4096 (order: 12, 32768 bytes)
Dec 17 08:21:20 thies kernel: Xen reported: 2327.578 MHz processor.
Dec 17 08:21:20 thies kernel: Console: colour VGA+ 80x25
Dec 17 08:21:20 thies kernel: Dentry cache hash table entries: 2097152 (order:
12, 16777216 bytes)
Dec 17 08:21:20 thies kernel: Inode-cache hash table entries: 1048576 (order:
11, 8388608 bytes)
Dec 17 08:21:20 thies kernel: Software IO TLB enabled: 
Dec 17 08:21:20 thies kernel:  Aperture:     64 megabytes
Dec 17 08:21:20 thies kernel:  Kernel range: 0xffff88000d9c3000 - 0xffff8800119c3000
Dec 17 08:21:20 thies kernel: PCI-DMA: Using software bounce buffering for IO
(SWIOTLB)
Dec 17 08:21:20 thies kernel: Memory: 9906672k/10199496k available (2357k kernel
code, 283920k reserved, 1326k data, 172k init)
Dec 17 08:21:20 thies kernel: Calibrating delay using timer specific routine..
5817.63 BogoMIPS (lpj=11635267)
Comment 2 Chris Lalancette 2007-12-17 10:27:14 EST
This is probably a dup of 250994; closing as such.

Chris Lalancette

*** This bug has been marked as a duplicate of 250994 ***

Note You need to log in before you can comment on or make changes to this bug.