Bug 425980 - Incorrect message list sorting: current view by sender
Incorrect message list sorting: current view by sender
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 10:51 EST by doublas
Modified: 2008-01-24 07:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 07:53:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of message view wrongly orderer by sender. (162.58 KB, image/jpeg)
2007-12-17 10:51 EST, doublas
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 504062 None None None Never

  None (edit)
Description doublas 2007-12-17 10:51:30 EST
Description of problem:

Sorting the main message view by sender returns a wrong sorting. It makes no
difference to click on the Subject header or to choose it from Main
Menu->Current View->By Sender.


Version-Release number of selected component (if applicable):

evolution-2.12.2-2.fc8
evolution-data-server-1.12.2-1.fc8
evolution-exchange-2.12.2-1.fc8
evolution-sharp-0.14.0.1-1.fc8
evolution-webcal-2.12.0-1.fc8


How reproducible:

It is always reproducible.


Steps to Reproduce:

1.  Select message sorting by sender from Main Menu->Current View->By Sender
2.
3.

  
Actual results:

Message sorting is wrong.


Expected results:

Message sorting should be by sender field.

Additional info:
Comment 1 doublas 2007-12-17 10:51:30 EST
Created attachment 289783 [details]
Screenshot of message view wrongly orderer by sender.
Comment 2 Milan Crha 2008-01-02 13:00:59 EST
Hello Doublas, I'm a bit confused here. By which column do you want to sort the
list? It seems to me like working for both Sender (From) or Subject. What locale
do you use? And what does it do when you run this command?
LANG=en_US.UTF-8 evolution

Comment 4 doublas 2008-01-03 04:16:32 EST
I'm trying to sort the main message list by Subject. I can do it by clicking on
the header or by selecting from the taskbar: View->Current View->By Subject. I
even defined a custom view and sorted it by subject, but all the tests ended
with the same wrong ordering.

I already use this same locale, LANG=en_US.UTF-8, so the check you suggest
returned the same result.

FWIW, I'm running Evolution in KDE, but I also found the same behaviour in Gnome.
Comment 5 Milan Crha 2008-01-15 09:18:04 EST
There has been done some changes in evolution-2.12.3-1.fc8, which is now in
updates-testing. Can you try with this version, please?
Comment 6 doublas 2008-01-16 10:46:44 EST
I tried evolution-2.12.3-1.fc8 and can confirm that the bug is still there :(
Comment 7 Milan Crha 2008-01-16 11:48:05 EST
Thanks for info, I will try to investigate more (it works for me, somehow). Can
you attach here a screen shot from actual Evolution, please? (I want to see the
names there, so I can check.) Is it possible that only some folders do this wrong?
Comment 8 doublas 2008-01-17 03:43:42 EST
There is already a screenshot attached to the bug report (attachment 289783 [details]).
The situation hasn't changed since bug opening so it's still valid. Please tell
me if you need additional examples.
Regarding folders, I checked several of them including Inbox and found the bug
every time so I suppose folder doesn't make a difference.
Comment 9 Milan Crha 2008-01-24 07:53:33 EST
I finally found the issue, thus I will close this as UPSTREAM and attach patch
for this issue to upstream bug. Thanks for your help.

Note You need to log in before you can comment on or make changes to this bug.