Bug 426009 - yum feature request for installing build dependencies
yum feature request for installing build dependencies
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 14:04 EST by Praveen A
Modified: 2014-01-21 18:01 EST (History)
6 users (show)

See Also:
Fixed In Version: 1.1.25-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 14:10:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Praveen A 2007-12-17 14:04:27 EST
Description of problem:
yum should provide an option to install build dependencies of a source rpm. apt
provides a similar option apt-get build-dep <package name>. Currently it is a
pain to manually resolve each dependency (that was the whole point of yum - not
to have you resolve the dependencies, right?). 

Additional info:

feature request
Comment 1 Seth Vidal 2007-12-17 14:10:38 EST
yum install yum-utils
yum-builddep pkg1 pkg2 pkg3

Comment 2 David Brown 2010-01-03 23:40:53 EST
so I'm going to say that there's something missing here.

So using apt you can install the build dependencies for any package on the system. 

For example, one could do an apt-get build-dep libgcc and it will look up the source package for libgcc and pull the build dependencies for that source package.

Currently on fedora12 this is what happens.

# yum-builddep libgcc
Enabling fedora-source repository
Enabling updates-source repository
No such package(s): libgcc.src
#

So currently what I'd have to do is lookup the src.rpm as follows:

yum-builddep `rpm -q --qf '%{SOURCERPM}' libgcc | awk '#MORE AWK SCRIPTING'`

This could be a lot cleaner and yum-builddep could be doing this for us.
Comment 3 Tim Lauridsen 2010-01-04 04:31:44 EST
Looks like yum-builddep could work a little smarter in the case where a package is build from a srpm with another name (libgcc != gcc).

I have made some changes to yum-builddep upstream to work around this issue.

http://yum.baseurl.org/gitweb?p=yum-utils.git;a=commitdiff;h=1bec4743be0d98c711ff5d5a4bb925b391a2b4be
Comment 4 Fedora Update System 2010-01-27 07:13:20 EST
yum-utils-1.1.25-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/yum-utils-1.1.25-1.fc12
Comment 5 Fedora Update System 2010-02-11 09:47:50 EST
yum-utils-1.1.25-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 David Brown 2010-02-11 11:46:14 EST
I'm unsure how complicated it would be to back port this to RHEL5. I'm thinking yum may need an update in RHEL5 to make this work there.

What are the chances this will get back ported to RHEL?
Comment 7 seth vidal 2010-02-11 11:53:54 EST
Take it up with your TAM or file an RFE for rhel5. But It will never get noticed on this bug.
Comment 8 James Antill 2010-02-11 12:27:40 EST
To expand ... there's a roughly 0% chance of this getting fixed in RHEL-5 at this point without a RHEL specific bug that is tied to customer.

Note You need to log in before you can comment on or make changes to this bug.