Bug 426018 - evince crashes using intel driver
evince crashes using intel driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 14:49 EST by David
Modified: 2013-04-02 00:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:01:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1003 bytes, text/plain)
2007-12-19 11:48 EST, David L.
no flags Details
Xorg.0.log (42.58 KB, text/plain)
2007-12-19 11:50 EST, David L.
no flags Details
xorg.0.log with xorg.conf removed (45.28 KB, text/plain)
2007-12-20 12:54 EST, David
no flags Details

  None (edit)
Description David 2007-12-17 14:49:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
evince crashed when I run evince with the xorg intel driver.

Here's the error I get:

evince /tmp/test.ps

Gdk-ERROR **: The program 'evince' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 729 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Abort (core dumped)


I created the ps file from a graphviz file with these contents:
digraph base {
"A"->"B" [ label = "C"]
}

Then I did this:
dot -Tps /tmp/test.dot > /tmp/test.ps

I'm running these versions of evince/Xorg:
evince-2.20.2-1.fc8
xorg-x11-server-Xorg-1.3.0.0-36.fc8

My smolt profile is here:
http://www.smolts.org/show?UUID=4f262ae0-66cb-4187-889a-e767b1f67807


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.1.1-7.fc8

How reproducible:
Always


Steps to Reproduce:
1. evince /tmp/test.ps  (see description)
2.
3.

Actual Results:
evince crashes with an X error.

Expected Results:
evince displays ps file.

Additional info:
Comment 1 David 2007-12-18 11:13:19 EST
I forgot to mention that the same procedure works fine on the same computer
when using vesa instead of i810 and it also works fine under a vnc session
on the same computer (both server and client) using the i810 driver.  It's
only when using the i810 driver without vnc that evince crashes and then it
crashes every time in both KDE and Gnome.
Comment 2 Matěj Cepl 2007-12-19 08:51:28 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 David L. 2007-12-19 11:48:33 EST
Created attachment 290040 [details]
xorg.conf

this is the xorg.conf with the "intel" driver specified.
Comment 4 David L. 2007-12-19 11:50:42 EST
Created attachment 290041 [details]
Xorg.0.log

This is the backup of the Xorg.0.log file from when I was using the "intel"
driver
Comment 5 David L. 2007-12-19 11:54:29 EST
(In reply to comment #2)
<snip>
> Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
> let X11 autodetect your display and video card? Attach to this bug
> /var/log/Xorg.0.log from this attempt as well, please.

I'll do this tomorrow once I have physical access to that computer.
But this is a new f8 installation, so I assume it will detect the
same thing again.  Or is install-time detection different from post
install detection?

Comment 6 Matěj Cepl 2007-12-20 02:24:09 EST
Yes, it is.
Comment 7 David 2007-12-20 12:54:44 EST
Created attachment 290176 [details]
xorg.0.log with xorg.conf removed
Comment 8 Adam Jackson 2008-02-12 11:07:30 EST
>  (Details: serial 729 error_code 11 request_code 53 minor_code 0)

53 is CreatePixmap.  And yeah, X will refuse to create pixmaps larger than 32k
wide or tall.

That said, I'm unable to reproduce this with evince 2.21.1-2.fc9.
Comment 9 Stanton J. Peale 2008-04-06 17:29:53 EDT
Before I installed a long list of updates after fixing a bug in the update
program, evince worked fine, But after installing the updates I got the above
error message when I tried to display a pdf file with evince.  This is April 6,
2008, and the above messages are all in Dec. 2007 except the last.  There was
never a fix given for the problem that is described.  What has happened in the
meantime, and how do I fix the bug in evince that was introduced by the updates?
My system has an ATI All-In-Wonder video card.

Stan Peale
04/06/08
P.S. I was warned by a colleague never to install the updates that arrive
unsolicited because they often break the system.  I am now a believer.
Comment 10 David 2008-05-19 11:30:55 EDT
This error doesn't seem to happen in fedora 9.  evince is still practically
useless when trying to look at a medium sized ps file generated with graphviz,
but I no longer get the X errors.  Now I get messages like this:

**** Unable to open the display device, quitting.
VMerror -25
rangecheck -15

** (evince:2979): WARNING **: Error rendering thumbnail
**** Unable to open the display device, quitting.
VMerror -25
**** Unable to open the display device, quitting.
VMerror -25


Anyway, if this doesn't look like an X problem now, I guess this bug can be
closed as fixed in f9 and I'll have to open a new one.  :(
Comment 11 David 2009-01-08 12:10:02 EST
This same problem (or one with the same signature) is back in fedora 10.

Evince crashes with this backtrace:

#0  memset () at ../sysdeps/i386/i686/memset.S:85
#1  0x00b94fd5 in pdf_page_render () at /usr/include/bits/string3.h:85
#2  pdf_document_render (document=0x83e6740, rc=0x83cde40) at ev-poppler.cc:522
#3  0x0078fa80 in ev_document_render (document=0x83e6740, rc=0x83cde40) at ev-document.c:241
#4  0x0806196c in ev_job_render_run (job=0x81b59f8) at ev-jobs.c:512
#5  0x0805f130 in ev_job_thread () at ev-job-scheduler.c:183
#6  ev_job_thread_proxy (data=0x0) at ev-job-scheduler.c:213
#7  0x003e2c6f in g_thread_create_proxy (data=0x8403b08) at gthread.c:635
#8  0x0035551f in start_thread (arg=0xb626bb90) at pthread_create.c:297
#9  0x0028b04e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

If I run evince under a vncserver session on the same computer, it runs fine.
Comment 12 David 2009-01-11 11:01:41 EST
I changed from closed to assigned since it is happening again.  I think a different bug that was introduced and subsequently fixed masked this bug during fedora 9 and it was never really fixed.
Comment 13 Matěj Cepl 2009-01-12 04:47:32 EST
(In reply to comment #12)
> I changed from closed to assigned since it is happening again.  I think a
> different bug that was introduced and subsequently fixed masked this bug during
> fedora 9 and it was never really fixed.

Why this isn't evince bug? I don't see anything in the backtrace from XOrg?
Reassigning
Comment 14 David 2009-01-12 20:26:08 EST
Maybe it is an evince bug, but it only happens when using the i810 driver, so I assigned it to that.
Comment 15 David 2009-02-03 10:57:22 EST
My monitor died yesterday and after setting up the replacement monitor, I haven't been able to reproduce this problem.  The bug is not fixed, but I will not be able to provide any additional debugging info.  But I did provide a backtrace, so I think somebody will have a good chance of finding the problem with what I already provided.
Comment 17 Bug Zapper 2009-11-18 05:09:03 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Bug Zapper 2009-12-18 01:01:51 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.